After f32 update on Acer Laptop: built-in keyboard not working

cross-posted here: https://stackoverflow.com/questions/63034429/after-f32-update-on-acer-laptop-built-in-keyboard-not-working
Hi there!
I’m quite new to Fedora and asking for your help with a keyboard issue.

Recently I updated my laptop from fedora 31 to fedora 32. When I tried to type my password on lockscreen I realized, that the build-in keyboard of my laptop isn’t working. Log in with external USB-Keyboard worked. [I already know that my touchpad is broken for some reason].

  • GNOME-Version 3.36.3., Fedora 32, Wayland, up to date

  • My Laptop: Acer Aspire E5-511-P7AT; Intel® Pentium® CPU N3530 @ 2.16GHz × 4; Intel® HD Graphics (BYT)

  • Update everything with sudo dnf update hasn’t solved the problem.

  • The Keyboard is working in BIOS. Therefore I assume, that the problem might be connected with libinput.
    Terminal Output (selection):

sudo libinput list-devices
Device: Logitech USB Keyboard
Kernel: /dev/input/event6
Group: 6
Seat: seat0, default
Capabilities: keyboard
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: n/a
Nat.scrolling: n/a
Middle emulation: n/a
Calibration: n/a
Scroll methods: none
Click methods: none
Disable-w-typing: n/a
Accel profiles: n/a
Rotation: n/a

Device: Logitech USB Keyboard Consumer Control
Kernel: /dev/input/event7
Group: 6
Seat: seat0, default
Capabilities: keyboard
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: n/a
Nat.scrolling: n/a
Middle emulation: n/a
Calibration: n/a
Scroll methods: none
Click methods: none
Disable-w-typing: n/a
Accel profiles: n/a
Rotation: n/a

Device: Logitech USB Keyboard System Control
Kernel: /dev/input/event14
Group: 6
Seat: seat0, default
Capabilities: keyboard
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: n/a
Nat.scrolling: n/a
Middle emulation: n/a
Calibration: n/a
Scroll methods: none
Click methods: none
Disable-w-typing: n/a
Accel profiles: n/a
Rotation: n/a

Device: Logitech USB Optical Mouse
Kernel: /dev/input/event5
Group: 7
Seat: seat0, default
Capabilities: pointer
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: disabled
Nat.scrolling: disabled
Middle emulation: disabled
Calibration: n/a
Scroll methods: button
Click methods: none
Disable-w-typing: n/a
Accel profiles: flat *adaptive
Rotation: n/a

Device: AT Translated Set 2 keyboard
Kernel: /dev/input/event4
Group: 10
Seat: seat0, default
Capabilities: keyboard
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: n/a
Nat.scrolling: n/a
Middle emulation: n/a
Calibration: n/a
Scroll methods: none
Click methods: none
Disable-w-typing: n/a
Accel profiles: n/a
Rotation: n/a

Device: Acer WMI hotkeys
Kernel: /dev/input/event12
Group: 11
Seat: seat0, default
Capabilities: keyboard
Tap-to-click: n/a
Tap-and-drag: n/a
Tap drag lock: n/a
Left-handed: n/a
Nat.scrolling: n/a
Middle emulation: n/a
Calibration: n/a
Scroll methods: none
Click methods: none
Disable-w-typing: n/a
Accel profiles: n/a
Rotation: n/a

  • AT Translated Set 2 keyboard seems to be the built-in keyboard. Running sudo libinput debug-events in terminal gives:

-event3 DEVICE_ADDED Power Button seat0 default group1 cap:k
-event8 DEVICE_ADDED Video Bus seat0 default group2 cap:k
-event1 DEVICE_ADDED Power Button seat0 default group3 cap:k
-event0 DEVICE_ADDED Lid Switch seat0 default group4 cap:S
-event2 DEVICE_ADDED Sleep Button seat0 default group5 cap:k
-event6 DEVICE_ADDED Logitech USB Keyboard seat0 default group6 cap:k
-event7 DEVICE_ADDED Logitech USB Keyboard Consumer Control seat0 default group6 cap:k
-event14 DEVICE_ADDED Logitech USB Keyboard System Control seat0 default group6 cap:k
-event5 DEVICE_ADDED Logitech USB Optical Mouse seat0 default group7 cap:p left scroll-nat scroll-button
-event13 DEVICE_ADDED HD WebCam: HD WebCam seat0 default group8 cap:k
-event9 DEVICE_ADDED Intel Virtual Button driver seat0 default group9 cap:kS
event9 SWITCH_TOGGLE +0.000s switch tablet-mode state 1
-event4 DEVICE_ADDED AT Translated Set 2 keyboard seat0 default group10 cap:k
-event12 DEVICE_ADDED Acer WMI hotkeys seat0 default group11 cap:k
-event5 POINTER_MOTION +0.000s -1.62/ 0.00 ( -5.00/ +0.00)

Pressing any key on the built-in keyboard give no respond in libinput debug-events, exept for some FN-keys (event4).
What can I do now to get this built-in keyboard to work?
I’m looking forward for your help.

Best regards
smallfire

1 Like

i have kind of the same problem. some of my keys are not working and im typing this using screen key board.please help us solve this problem

Hi @vgaetera, thanks for your answer.

  • I’m running libinput 1.16.0, but built-in keyboard is working. How to downgrade libinput? Probably touchpad will work then …

  • I’ve tried several steps here (askfedora won’t let me edit my original question 6th time).

1 Like
sudo dnf downgrade libinput

Reboot to apply changes.

Thanks, but downgrade to libinput 1.15.4. didn’t solved it in my case. I even have no sign of my touchpad neither in xinput list nor in sudo libinput list-devices.

1 Like

Hi. I have the same problem with my asus Q504U keyboard and touchpad after a fresh reinstall of f32, but the problem start after the first dnf update. This means, if I keep f32 without update, everything works perfect. After the update, both keyboard and touchpad does not work at all and, in order to have access to my computer I either connect and external keyboard via usb or use the touchscreen keyboard ob my laptop. Keyboard and touchpad works once on bios, which is curious.
any suggestions?
Thanks in advance

With the latest kernel update in Fedora 32 (kernel version 5.8.11-200.fc32.x86_64) touchpad and keyboard work again on my ASUS laptop (model R541U / X541UAK) :slight_smile:

1 Like