After Firefox update, web pages are shown with a white corners

Hi, this morning I’ve updated Firefox 66 to version 67 on Fedora 29, but now it renders all web pages with white corners, e.g. in this screenshot. I don’t know how to downgrade Firefox package to version 66, because dnf will try to downgrade to version 62. Only me have this bug and, if it is possible, how can I resolve it?

Hello @ema-pe. Welcome to the community! Please take a minute to look at the posts in the #start-here category if you’ve not had a chance yet. They contain useful information on using the platform well.

Would you be able to create a new firefox profile to check if the issue persists there also? You can run the firefox profile manager as documented here:

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Hi, I created a temporary profile and… the problem disappeared! I don’t understand that, maybe I’ve broke some configuration on my every-day profile?

1 Like

Yes, that would indicate something broken with your regular profile. Do you have any extensions installed? You can export your history etc from one profile and import it into another one. Or you should be able to use Firefox Sync to back things up and then sync back to the new profile too.

1 Like

Hi, I solved the problem. It wasn’t a Firefox’s problem, but it is a feature of the program to prevent fingerprinting of screen size. This option is disabled by default, but I use ghacks-user.js, a custom configuration for Firefox specialised for privacy and security and here it is enabled by default. This issue on Github explains the effect of this option, so I simple disabled it on my custom configuration: gitlab.com/ema-pe/dotfiles/commit/522c25c9e0e5ed239130fe786f3c3032be77bf32

p.s. I noticed that I can’t post more than 2 links because I’m a new user here, so I put the last link in a different format.

1 Like

@ema-pe, thanks for reporting your finds.

I though that it can be anti-fingerprinting feature (I’ve heard about Firefox considering to make it the default one), but just enabling ResistFingerprinting option in my Firefox didn’t produce results you’ve shown.

We now know why)