After Updated Fedora 35 Internal or External Wifi Adapters Both are Not showing

After Updated Fedora 35 Internal or External Wifi Adapters both are not showing… present kernel now 5.16.11 what i am using after updated…

I updated fedora 35 so many times before there are no wifi issues…but now the first time i am seeing this wifi issue…

May be you want to try boot to older kernel (for exp. kernel 5.16.10) then run lspci -nnv. Find part “Network controller”, copy and save it to text file. Then boot to newly installed kernel and run the command again.

From “Network controller” there a line Kernel driver in use: ... and make sure for both kernel have same modules in use. If both have same module and the Wifi not work for newly kernel version, the best way is report it to bugzilla.redhat.com against the kernel.

yeah i checked…

for kernel 5.16.9-200.fc35.x86_64

03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
	Subsystem: Fujitsu Limited. Device [10cf:1537]
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f0500000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
	Capabilities: [170] Power Budgeting <?>
	Kernel driver in use: ath9k
	Kernel modules: ath9k

for kernel 5.16.11-200.fc35.x86_64

03:00.0 Network controller [0280]: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
	Subsystem: Fujitsu Limited. Device [10cf:1537]
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at f0500000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-15-17-ff-ff-24-14-12
	Capabilities: [170] Power Budgeting <?>
	Kernel driver in use: ath9k
	Kernel modules: ath9k

they have like this but in both wifi not working but in past wifi worked in kernel 5.16.9…

and recently i installed kernel 5.16.9 2 or 3 hours before only because to check for wifi working or not in kernel 5.16.9 and now not working…

what to do…?

1 Like

My bad, may be I’m not asking clearly. Above look like are different devices, the first one is Atheros the second one are Realtek. If you connect it both, there should be have two result for “Network controller” Wifi.

Initially I just want to check the internal Wifi without connecting the external Wifi.

1 Like

Hai,

Now i edited my reply correctly…and they both are same device.

Would you like to try add kernel parameter ath9k.ps_enable=0 by running:

sudo grubby --args="ath9k.ps_enable=0" --update-kernel=ALL

then reboot your system. This command are for disabling power save.

You could check the available argument from modinfo MODULE_NAME, for above case modinfo ath9k.

There also I read somewhere if the connection not stable you could use ath9k.nohwcrypt=1.

1 Like

still same problem. after running this command and rebooted also.

sudo grubby --args="ath9k.ps_enable=0" --update-kernel=ALL

with this command
sudo lshw -C network

*-network:0 DISABLED
       description: Wireless interface
       physical id: 2
       bus info: usb@2:1.2
       logical name: wlp0s29u1u2
       serial: c2:0c:b0:5b:4c:52
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=mt7601u driverversion=5.16.12-200.fc35.x86_64 firmware=N/A link=no multicast=yes wireless=IEEE 802.11

What desktop environment on your system (for example Gnome, KDE, etc.)?

That could be means it’s currently disabled from the setting or currently on airplane mode. If you’re using Gnome you could go to Gnome Settings then find Wi-Fi or Network and check if it currently enabled or not.

1 Like

Gnome…

I tried that also now what…!!

I use nearly the same internal wifi card chipset but don’t have problem. I just upgrade to new kernel in fedora 35

1 Like

I use nearly the same internal wifi chipset with newer kernel in fedora 35 but I don’t have problem since fresh install fedora 35. Maybe you just type this sudo systemctl restart NetworkManager

What’s the output of

rfkill list

?
If rf is not blocked, …

… it let’s me think we should take a look at NetworkManager.state:

sudo cat /var/lib/NetworkManager/NetworkManager.state

What does it say there?

2 Likes
rfkill list
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes

sudo cat /var/lib/NetworkManager/NetworkManager.state
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

That is your issue right there.
I assume your laptop has a hardware switch for enabling/disabling wifi, maybe it’s a keyboard key combination.

3 Likes

Your reply make very helpful to me and my issue solved by only simple thing…

i removed my laptop battery and attached the battery again that 's all…

1 Like

@skmdab Just want to know, did your system run dual boot with Windows? If yes, may be you want to disable Windows fast boot. This Windows feature sometime will lock some devices and Linux have some trouble when using it.

No only Fedora linux i don’t have Windows

I had forgotten about the fast boot interference, but I also seem to remember that when some of the wifi adapters are disabled in windows it hard blocks them in linux and requires that they be enabled in windows to fix the issue in linux.

1 Like