All flatpak apps fail to start after upgrade to 33

Hi!

Ich recently updated to Fedora 33 without issues. However, when I tried to open a flatpak application nothing happened. I then tried to start an app using the terminal, with the following output:

Output of flatpak run com.github.xournalpp.xournalpp
Gtk-Message: 11:40:48.444: Failed to load module "pk-gtk-module"
Gtk-Message: 11:40:48.444: Failed to load module "canberra-gtk-module"
Gtk-Message: 11:40:48.445: Failed to load module "pk-gtk-module"
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../../src/pcm/pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib ../../../src/pcm/pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib ../../../src/pcm/pcm.c:2564:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_route_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_route_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_route_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_route_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_route_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_route_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_route_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_route_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_empty_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_empty_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_hooks_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_hooks_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_hooks_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_hooks_open is not defined inside [builtin]
ALSA lib ../../oss/pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib ../../oss/pcm_oss.c:377:(_snd_pcm_oss_open) Unknown field port
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_plug_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_plug_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_plug_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_plug_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_plug_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_plug_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_plug_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_plug_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_plug_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_plug_open is not defined inside [builtin]
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_plug_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_plug_open is not defined inside [builtin]
ALSA lib ../../usb_stream/pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib ../../usb_stream/pcm_usb_stream.c:486:(_snd_pcm_usb_stream_open) Invalid type for card
ALSA lib ../../src/dlmisc.c:170:(snd_dlsym_verify) unable to verify version for symbol _snd_pcm_dmix_open
ALSA lib ../../src/dlmisc.c:295:(snd1_dlobj_cache_get) symbol _snd_pcm_dmix_open is not defined inside [builtin]

(com.github.xournalpp.xournalpp:2): Gtk-WARNING **: 11:40:48.539: Theme parsing error: <data>:1:22: Junk at end of value for font-family

(com.github.xournalpp.xournalpp:2): Gtk-WARNING **: 11:40:48.563: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:../../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /run/host/share/icons/Flat-Remix-Blue-Dark/apps/scalable/image-missing.svg: Error opening file /run/host/share/icons/Flat-Remix-Blue-Dark/apps/scalable/image-missing.svg: No such file or directory (g-io-error-quark, 1)

** (com.github.xournalpp.xournalpp:2): WARNING **: 11:40:48.563: [Crash Handler] Crashed with signal 6

** (com.github.xournalpp.xournalpp:2): WARNING **: 11:40:48.564: [Crash Handler] Wrote crash log to: /home/shayden/.xournalpp/errorlogs/errorlog.20201214-114048.log
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found
sh: addr2line: command not found

** (com.github.xournalpp.xournalpp:2): WARNING **: 11:40:48.692: Trying to emergency save the current open document…

** (com.github.xournalpp.xournalpp:2): WARNING **: 11:40:48.692: Successfully saved document to "/home/shayden/.xournalpp//emergencysave.xopp"

I tried to google the issue, but haven’t found any content on this issue (yet). So I need to ask you :slight_smile:

All flatpak apps are up-to-date since flatpak update yiels nothing. The version of flatpak is 1.8.3.

1 Like

Due to the character limit on the post I add the output of fpaste --sysinfo here:

1 Like

Hi @znert, welcome to the forum! Please take a minute to go through the introductory posts in the #start-here category when you have a minute. They include some useful info.

Not sure what would cause this. I upgraded too and my FlatPaks continued to work. Try removing and re-installing the FlatPak?

Does this happen with all FlatPaks, or is the issue limited to this one?

1 Like

Can you check: Flatpak applications are broken when using packaged system-wide theme #161

FYI, it looks like Adwaita or Paper Icons should work if that’s the issue.

Thanks

1 Like

I thought it happens with all flatpaks, but apparently only some of them are not starting:

  • starting:
    • com.axosoft.GitKraken
    • com.discordapp.Discord
    • com.getpostman.Postman
    • com.slack.Slack
    • org.gimp.GIMP
    • org.gnome.GHex
    • org.zotero.Zotero
  • not starting:
    • com.github.xournalpp.xournalpp
    • org.gnome.Epiphany
    • org.gnome.Geary
    • org.gnome.seahorse.Application

(Note: the gnome apps appear to be logging similar errors, but different from the one I posted earlier. If needed I will post all of the logs. For now this seems too cumbersome :smiley:)

Here is my full list of installed apps:

Output of flatpak list
Name                                         Application ID                                           Version       Branch      Origin       Installation
GitKraken                                    com.axosoft.GitKraken                                    7.4.1         stable      flathub      system
Discord                                      com.discordapp.Discord                                   0.0.13        stable      flathub      system
Postman                                      com.getpostman.Postman                                   7.36.0        stable      flathub      system
Xournal++                                    com.github.xournalpp.xournalpp                           1.0.19        stable      flathub      system
Slack                                        com.slack.Slack                                          4.12.0        stable      flathub      system
Fedora Platform                              org.fedoraproject.Platform                               33            f33         fedora       system
Freedesktop Platform                         org.freedesktop.Platform                                 18.08.39      18.08       flathub      system
Freedesktop Platform                         org.freedesktop.Platform                                 19.08.12      19.08       flathub      system
Freedesktop Platform                         org.freedesktop.Platform                                 20.08.2       20.08       flathub      system
default                                      org.freedesktop.Platform.GL.default                                    19.08       flathub      system
default                                      org.freedesktop.Platform.GL.default                                    20.08       flathub      system
Intel VAAPI Driver                           org.freedesktop.Platform.VAAPI.Intel                                   1.6         flathub      system
Intel                                        org.freedesktop.Platform.VAAPI.Intel                                   18.08       flathub      system
Intel                                        org.freedesktop.Platform.VAAPI.Intel                                   19.08       flathub      system
Intel                                        org.freedesktop.Platform.VAAPI.Intel                                   20.08       flathub      system
FFmpeg extension                             org.freedesktop.Platform.ffmpeg                                        1.6         flathub      system
html5-codecs                                 org.freedesktop.Platform.html5-codecs                                  18.08       flathub      system
openh264                                     org.freedesktop.Platform.openh264                                      19.08       flathub      system
openh264                                     org.freedesktop.Platform.openh264                        2.1.0         2.0         flathub      system
GNU Image Manipulation Program               org.gimp.GIMP                                            2.10.22       stable      flathub      system
Manual                                       org.gimp.GIMP.Manual                                                   2.10        flathub      system
GNOME Web                                    org.gnome.Epiphany                                       3.38.0        stable      fedora       system
GNOME Hex Editor                             org.gnome.GHex                                           3.18.4        stable      fedora       system
Geary                                        org.gnome.Geary                                          3.38.1        stable      flathub      system
GNOME Application Platform version 3.26      org.gnome.Platform                                                     3.26        flathub      system
GNOME Application Platform version 3.28      org.gnome.Platform                                                     3.28        flathub      system
GNOME Application Platform version 3.30      org.gnome.Platform                                                     3.30        flathub      system
GNOME Application Platform version 3.32      org.gnome.Platform                                                     3.32        flathub      system
GNOME Application Platform version 3.34      org.gnome.Platform                                                     3.34        flathub      system
GNOME Application Platform version 3.36      org.gnome.Platform                                                     3.36        flathub      system
GNOME Application Platform version 3.38      org.gnome.Platform                                                     3.38        flathub      system
Seahorse                                     org.gnome.seahorse.Application                           3.38.0.1      stable      flathub      system
Adapta-Nokto-Eta Gtk+ theme                  org.gtk.Gtk3theme.Adapta-Nokto-Eta                                     3.22        flathub      system
KDE Application Platform                     org.kde.Platform                                                       5.12        flathub      system
QGnomePlatform                               org.kde.PlatformTheme.QGnomePlatform                                   5.12        flathub      system
QtSNI                                        org.kde.PlatformTheme.QtSNI                                            5.12        flathub      system
QGnomePlatform-decoration                    org.kde.WaylandDecoration.QGnomePlatform-decoration                    5.12        flathub      system
Zotero                                       org.zotero.Zotero                                        5.0.93        stable      flathub      system

I tried to copy my themes to the local .themes, but it did not work.

Installed the icon theme (Flat-Remix) and geary from flathub, is this the same’ish error you are recieving?
Starting Geary

Did you just copy the folder from /usr/share/icons? If so that likely has the same issue with symlinks.

There is an update for the flat-remix-icon-theme it was pending/testing as I write this but includes the same fix that was done for Paper Icons from the earlier posted flatpak issue.

This appeared to resolve things on my install.

Once it reaches testing if you’d like to test early should be able to install with:
sudo dnf install flat-remix-icon-theme --enablerepo=updates-testing

FYI, this only enables updates-testing for this transaction not permanently.

or you could manually download from koji

or wait for it to make it through the process.

ref: https://fedoraproject.org/wiki/QA:Updates_Testing

Thanks

1 Like

Thanks a lot for your response, however, updating the icon theme and/or copying /usr/share/icons to ~/.icons didn’t help sadly. Maybe a reboot will do, but I currently need my laptop so I will update later.

I does look very similar, here is the full output:

*[wrn] 14:45:42.0156 geary:application-certificate-manager.vala:74: No GCR slot URIs found, GCR certificate pinning unavailable
*[wrn] 14:45:42.0372 Gtk:Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
Gtk:ERROR:../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /run/host/share/icons/Flat-Remix-Blue-Dark/status/scalable/512/image-missing.svg: Error opening file /run/host/share/icons/Flat-Remix-Blue-Dark/status/scalable/512/image-missing.svg: No such file or directory (g-io-error-quark, 1)
Bail out! Gtk:ERROR:../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /run/host/share/icons/Flat-Remix-Blue-Dark/status/scalable/512/image-missing.svg: Error opening file /run/host/share/icons/Flat-Remix-Blue-Dark/status/scalable/512/image-missing.svg: No such file or directory (g-io-error-quark, 1)
sudo dnf install binutils
sudo dnf provides \*/addr2line

https://dnf.readthedocs.io/en/latest/command_ref.html#provides-command-label

Nothing to do.

Looks like this command lists all packages that provide a file named “addr2line”, correct? Coincidentally I already have all mentioned packages installed (binutils and golang-(src|bin)).

I think the issue isn’t really my machine, but the “VM”/“container” used by flatpak.

1 Like

The update got pushed to testing if you want to try

sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f6807212fe

https://bodhi.fedoraproject.org/updates/FEDORA-2020-f6807212fe

Thanks

1 Like