Allow application to run in the background

Hi,
I recently upgraded to Fedora 31 and after a while got the notification that one application was running in the background. Curious about the new function I clicked “forbid” and gnome killed the app.
But it remembers my choice and now continues to kill the app every time it’s not in focus.
I need to hit the “undo” on this, but can’t figure out where the setting is.
The obvious place to look was settings->applications, but it’s not there.
Any help would be appreciated. Thanks. :]

1 Like

In case you’ll get no answer: just create a new user, and copy the files from the old one, when needed.

I was about to do just that and interestingly enough, it seems the setting doesn’t survive relog. :]

Thanks for help.

I would still like to know more about this option: where to find it, how to switch it on and off permanently, etc.

1 Like

I did some research and it looks like there are plans/suggestions to add “background activity” button in the Settings section.

For now, we can remove background permissions for all flatpak’s :
flatpak permission-remove background background

or for specific application:
flatpak permission-reset application name

More info here:

6 Likes

A switch in the Settings (Control Center) panel has been added in 3.35.90 https://gitlab.gnome.org/GNOME/gnome-control-center/-/commit/edc4044f84af14b23e4cfbc927831dac72b10b01

This will be present in GNOME next release (3.36) that will be included in Fedora 32.

7 Likes

Thanks, in the end the permission didn’t reset with relog only. I guess sometimes it’s just not detecting focus correctly and that’s why it did run in the background.

flatpak permission-reset application_name

fixed the issue.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.