AMD Radeon Vega Graphics not detected

I’m using an AMD Ryzen 5 2400G with Radeon Vega Graphics, but my system doesn’t seem to be taking advantage of the integrated graphics.

From what I understand:

  • All AMD drivers ship with the kernel (linux-firmware) in f36, so no special packages should be necessary
  • Wayland support for AMD is still experimental (not shipped with f36?)

I was able to get smooth animations and all that from my previous Ubuntu installation. The part that’s really tripping me up about this is that even when I switch to an Xorg session, the drivers don’t seem to be in use. How do I troubleshoot this?

This is absolutely not the case. Radeon graphics are very much supported in Fedora with Wayland and in the Fedora shipped kernel.

It might be helpful to do a dmesg | grep -i radeon and report any errors you find here that might give us a clue. If for some reason it’s failing to load, the graphics might fall back to the vesa driver and then you would see a degradation of performance, but there should be clues about it in the logs.

Thanks for the clarification. No output other than

$ dmesg | egrep -i 'radeon|amdgpu'
smpboot: CPU0: AMD Ryzen 5 2400G with Radeon Vega Graphics (family: 0x17, model: 0x11, stepping: 0x0

Here’s some more information, not sure exactly what to try.

$ inxi -G --display
Graphics:
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Mobile Series]
    driver: N/A
  Display: server: X.Org v: 1.22.1.3 with: Xwayland v: 22.1.3 driver: X:
    loaded: modesetting,radeon,vesa unloaded: fbdev gpu: N/A
    resolution: 1104x621~60Hz
  OpenGL: renderer: llvmpipe (LLVM 14.0.0 256 bits) v: 4.5 Mesa 22.1.3

Let me know what else I can provide.

That’s interesting. It seems it is properly detecting your hardware and loading the radeon driver appropriately. I wouldn’t expect Xorg to perform better than Wayland (in fact, for this hardware, I’d expect Wayland to perform nominally better).

Since it is integrated, one thing you might do is check your BIOS settings to see if you can allocate more memory to the GPU. It shouldn’t make it “faster”, but might make a difference if you’re using multiple monitors or higher resolutions and framerates.

Also, make sure you’re running the latest available kernel in the Fedora repos as that’s where driver updates will land and there are generally quite a few updates for Ryzen and Radeon hardware between each minor point release (ie, 5.17 to 5.18).

Seems like amdgpu is missing or disabled and you’re using CPU rendering. What’s the output of:

cat /proc/cmdline
dnf -C list installed linux-firmware
1 Like
$ cat /proc/cmdline
BOOT_IMAGE=(hd0,gpt2)/vmlinuz-5.18.13-200.fc36.x86_64 root=UUID=627fe513-d034-44d1-bf10-412bb8455f8c ro rootflags=subvol=root nomodeset rhgb quiet
$ dnf -C list installed linux-firmware
Installed Packages
linux-firmware.noarch    20220708-136.fc36    @updates

nomodeset blocks gpu drivers and leaves you with software renedering (LLVMpipe). It’s added to kernel parameters if you start installation in basic graphics mode.
Test booting without nomedeset: Making Temporary Changes to a GRUB 2 Menu
If it works fine, remove it permanently: Making Persistent Changes to a GRUB 2 Menu Using the grubby Tool

1 Like

Oh that’s exactly what my nightmarish installation forced me to do! This perfectly explains why amdgpu would get loaded but rendering would still fall back to llvmpipe. Thank you for the guides! Now to try it out.

1 Like

All fixed now. Thanks so much. It even fixed a completely different issue that I thought was unrelated.

1 Like

Have a great time using Fedora!

1 Like