Amdgpu.dpm=0 and low frame rates

I set amdgpu.dpm=0 in the kernal parameters to see if it solves a problem I have with fedora completely freezing every so often. Problem is it resulted in me getting very low frame rates playing games.

Anyone know why? I would have expected it to result in my gpu having more power all the time, not less.

With amdgpu.dpm=0 you disabled Dynamic Power Management, which dynamically changes clock speeds and voltage based on GPU load.
You can change performance profiles manually (now you’re probably locked to low boot-up defaults), but that won’t be as effective as letting GPU/driver manage it, so it’s good for a temporary workaround, until you report the original issue and someone fixes the driver:
https://wiki.archlinux.org/title/AMDGPU#Power_profiles

I can’t run any of the commands in that document.

/sys/class/drm/card0/device/pp_power_profile_mode doesn’t seem to exists and sudo echo "manual" > /sys/class/drm/card0/device/power_dpm_force_performance_level says I don’t have permission.

How can I not have permission when I am using sudo??

Maybe booting with amdgpu.dpm=0 completely disables DPM without possibility to manage it manually, try again after booting without it.

Look at overclocking section, there are some ideas for configuring DPM if it causes issues.
Do you see something related to your issue in troubleshooting section?

Hi, every parameter we add to kernel parameter to solve some bugs (not to enhance the system), I think it worth to try to remove it each time we have new kernel upgrade. But if it not works we can add it back.