AMDGPU Overdrive not working on Fedora 31 64 bit

I was happily using overdrive on my RX 560 and made some changes to grub and it doesn’t work anymore. I made changes to grub with grub-customizer and then ran the grubby command to add the parameter amdgpu.ppfeaturemask=0xffffffff to the kernel but even though these steps have worked before it is not the case anymore.


/etc/default/grub

GRUB_TIMEOUT=“0”
GRUB_DISTRIBUTOR="(sed 's, release .*,g’ /etc/system-release)"
GRUB_DEFAULT=“0”
GRUB_DISABLE_SUBMENU=“true”
#GRUB_TERMINAL_OUTPUT=“console”
GRUB_CMDLINE_LINUX_DEFAULT=“resume=UUID=90416566-7972-4322-96dc-722d764f06cb amdgpu.ppfeaturemask=0xffffffff rhgb qui
et splash”
#GRUB_DISABLE_RECOVERY=“true”
GRUB_SAVEDEFAULT=“false”
GRUB_GFXMODE=“1920x1080”
GRUB_HIDDEN_TIMEOUT=“5”

#GRUB_TERMINAL_INPUT=“console”
#GRUB_DISABLE_OS_PROBER=“false”
GRUB_THEME="/boot/grub/themes/megano-grub-fedora/theme.txt"
GRUB_CMDLINE_LINUX_DEFAULT=""
#GRUB_DISABLE_LINUX_RECOVERY=“true”


sudo grubby --update-kernel=ALL --args="amdgpu.ppfeaturemask=0xffffffff"

sudo grub2-editenv list | grep kernelopts
kernelopts=root=UUID=ae4b73bc-7275-4228-8152-4f35ce5f6044 ro resume=UUID=90416566-7972-4322-96dc-722d764f06cb rhgb qu
iet splash amdgpu.ppfeaturemask=0xffffffff
printf "0x%08x\n" $(cat /sys/module/amdgpu/parameters/ppfeaturemask)
0xffffbfff

check ---- line

"GRUB_CMDLINE_LINUX_DEFAULT=“resume=UUID=90416566-7972-4322-96dc-722d764f06cb amdgpu.ppfeaturemask=0xffffffff rhgb qui
et splash”
should be like

"GRUB_CMDLINE_LINUX_DEFAULT=“resume=UUID=90416566-7972-4322-96dc-722d764f06cb rhgb quiet splash amdgpu.ppfeaturemask=0xffffffff ”

end
GRUB_CMDLINE_LINUX_DEFAULT=""
to
#GRUB_CMDLINE_LINUX_DEFAULT=""

I set the parameter alone and it worked! Using grub cutomizer though GRUB_ENABLE_BLSCFG to false it seems like is not set in the etc/default/grub file, that’s weird. Ihave that to false because I want to set a background image.

GRUB_TIMEOUT="15"
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT="0"
GRUB_DISABLE_SUBMENU="true"
#GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="resume=UUID=90416566-7972-4322-96dc-722d764f06cb rhgb quiet splash"
#GRUB_DISABLE_RECOVERY="true"
GRUB_SAVEDEFAULT="false"
GRUB_GFXMODE="1920x1080"
#GRUB_HIDDEN_TIMEOUT="5"
#GRUB_TERMINAL_INPUT="console"
#GRUB_DISABLE_OS_PROBER="false"
#GRUB_THEME="/boot/grub/themes/megano-grub-fedora/theme.txt"
GRUB_CMDLINE_LINUX_DEFAULT=""
#GRUB_DISABLE_LINUX_RECOVERY="true"
export GRUB_COLOR_NORMAL="light-gray/black"
export GRUB_COLOR_HIGHLIGHT="magenta/black"
GRUB_BACKGROUND="/boot/grub2/themes/system/background.png"
GRUB_ENABLE_BLSCFG="false"
GRUB_CMDLINE_LINUX_DEFAULT="amdgpu.ppfeaturemask=0xfffd7fff"

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.