Application sound always starts at around 90%

Whenever, I open Firefox to play media with an embedded player, which is unable to control the volume, the volume level will be set to roughly 85-90%, which is pretty noisy on my sound system. While other players, like Rhythmbox or embedded players able to set the volume (e.g. YouTube), will remain at the setting it was set up, sound from those other non-controllable players (e.g. on Bandcamp) jump right back to the heightened level as soon as

  • one mutes the tab, then unmutes it, or
  • changes the sound file (either manually or when the player ended the previous sound file and opens the next).

That being said: I can change the application sound to the level I would like to have it. However, I need to do this every time the above criteria is being met.

Is there a way to make PulseAudio, Firefox or whatever else is responsible to tune it down and remember that level for this application?

A workaround would be to lower the system-wide sound, which is already at 50% even further. However, other sound, including YouTube would then be pretty low as well, which is undesirable.

At first I thought that even Rhythmbox was affected, but this was due to a GNOME extension (Mpris Indicator Button), which I disabled. Though it leads me to believe that this is not simply a Firefox issue, but (potentially) stemming from PulseAudio when not getting any initial volume level request from a player.

While I do not have a current comparison, I cannot recall it being so annoying in the past. So, something must have changed within Fedora 32, PulseAudio and/or GNOME or while less likely, maybe even Firefox.

Is this a bug or can the “default” application volume be set up somewhere I was not looking?

1 Like

Could your problem be related to this setting?

$ gsettings describe org.gnome.desktop.sound allow-volume-above-100-percent
Whether volume can be set above 100%, using software amplification.

@vgaetera, I sincerely doubt it. The two reasons are:

  • It is set to false (default)
  • this affects global volume levels rather than the default starting volume of every application

The “GNOME Tweaks” application also provides the following information on that particular setting:
“Allows raising the volume above 100%. This can result in loss of audio quality; it is better to increase application volume settings, if possible.”

Since I already stated that my global volume levels are set to 50%, which is enough for me, there is no benefit of having this setting enabled as it would not make any difference until I increase the volume to over 100%. Since I am not in need for hearing loss over the course of years due to listening to loud music, I actually heed the recommendation given and keep it off as well as my global volume typically to 50%.

1 Like

Try this method:
https://linuxhint.com/per_application_sound_volume_ubuntu/

You can also reset PulseAudio configuration by renaming ~/.config/pulse.

@vgaetera, the method you are suggesting describes an issue I do not have. I can use the per-application sliders independently from the global system sound volume. This is evident already as I mentioned that my system sound is at 50% while the per-application volume control is at a way higher volume, namely around 85-90%. When moving said application volume slider, the global volume slider does not budge. I have seen this behavior way back in the past, but no longer recently.

I also tried removing the ~/.config/pulse directory, but it did not help either.

I possibly need to mention:
I may be atypical when installing a fresh copy of an operating system, but I usually move all dot-files into a sub directory, allowing them to be recreated when logging on to GNOME and only move the most vital back (e.g. parts of the Evolution configuration). So, Pulse Audio was as set by Fedora 32 and not carried over from any previous installments.

Detailed Summary:

  • Fedora 32 is freshly installed (using server(*), then upgraded to workstation, by installing the @"Fedora Workstation" package group)
  • initial setup following the installation is done by some scripts I wrote to install some basic extra packages as well as doing some configuration adjustment
  • the only setting I ever touch using said scripts for PulseAudio is commenting out load-module module-role-cork ("/etc/pulse/default.pa"), which stops music playing after each song when using a headset with, e.g. TeamSpeak while listening to music
  • global volume settings are set to 50% volume
  • application sound appears to be set at around ~90% per application and can be modified while sound is active
  • applications which do not have any controls to adjust volume (e.g. browser with some embedded media), will reset the application volume to the default each time they start using the sound system (e.g. after unmuting or after changing media); an example can be tried to reproduce when playing back media on www.bandcamp.com, but there are possibly others as well
  • Players like Rhythmbox or games like OpenTTD, do save their volume levels and set them back to the saved values; exception is when you have tools running in parallel to tap on anything (e.g. GNOME extension “Mpris Indicator Button”), which then sets the volume back to the default for the application it affects

So, my initial question remains:
Did something change in Fedora 32 (or its components) to no longer save the volume settings per application or is there a (new?) setting, which can be used to remember the settings PulseAudio shall use when playing back sound?


(*) I use the server ISO due to the fact that I also run a server and just using one ISO to fits them all saves me an additional download of the DVD and, more importantly, it allows me to slim down the Workstation installation slightly with just the tools needed as well as install even the initial admin user enterprise-style without having to change it afterwards.

1 Like