Applications sometimes not opening on primary monitor

I’m using F36 with Wayland on GNOME. I can successfully set my primary monitor (and this persists). However, some applications open on the wrong monitor and I need to move it to my primary monitor. I do not experience this same issue on X11.

I’ve reviewed both Changing the primary monitor - #2 by oprizal and Gnome Login Menu On Wrong Screen - #2 by vgaetera. The latter instructions work perfectly fine for GDM. The former instructions work temporarily, but the problem returns on reboot.

Things I’ve tried:

  • Turning the monitor off in the display settings instead of unplugging it

  • Deleting and recreating monitors.xml

  • Plugging the second monitor into a different port

This is the contents of monitor.xml:

<monitors version="2">
  <configuration>
    <logicalmonitor>
      <x>1360</x>
      <y>0</y>
      <scale>1</scale>
      <monitor>
        <monitorspec>
          <connector>DVI-D-1</connector>
          <vendor>HWP</vendor>
          <product>HP w185e</product>
          <serial>CNT13123WN</serial>
        </monitorspec>
        <mode>
          <width>1366</width>
          <height>768</height>
          <rate>59.789539337158203</rate>
        </mode>
      </monitor>
    </logicalmonitor>
    <logicalmonitor>
      <x>0</x>
      <y>0</y>
      <scale>1</scale>
      <primary>yes</primary>
      <monitor>
        <monitorspec>
          <connector>HDMI-1</connector>
          <vendor>SAM</vendor>
          <product>SAMSUNG</product>
          <serial>0x00000000</serial>
        </monitorspec>
        <mode>
          <width>1360</width>
          <height>768</height>
          <rate>60.015163421630859</rate>
        </mode>
      </monitor>
    </logicalmonitor>
  </configuration>
</monitors>

The same is happening in my case when switching to XOrg., after a bad experience with Wayland, and not being able to share screens in any type of meeting application.

Also have this issue, it’s pretty annoying. It also seems to always be the same applications that decide to open on the wrong (secondary) monitor. E.g. System Monitor always opens on the secondary monitor.

Maybe worth noting, inside my Display Settings, my Primary Display is actually the monitor marked as the second one. Is there a way to change this? Might be related to the issue.

image

Welcome to ask.fedora @jfaz1

Please read before posting. On your print screen you see the Primary monitor field. Click on the arrow down to see what is available.

Hey @ilikelinux, thanks for the response! The correct monitor is set as the primary monitor. What I’m referring to is the “number” of each monitor. Notice how the primary display is a monitor with 2 on it.
My issue is that even though I have 2 set as the primary display, some applications will always open on 1 for some reason. I was just theorizing that maybe the number has something to do with it, even if it’s not set as the primary monitor.

I swapped the DP cables and the numbers readjusted, then rebooted after deleting monitors.xml. Now it looks like this, which makes a bit more sense:
image

Unfortunately that did nothing, the same applications still open in the other monitor, regardless of what monitor has focus. For example, System Monitor always opens on the secondary monitor, no matter what I try.

1 Like