Ask.fedoraproject.org and id.fedoraproject.org issues

ask . fedoraproject . org and id . fedoraproject . org wont work with chrome / vivaldi / opera

Tried to login into bugs . fedoraproject . org and others. They all want me to use id . fedoraproject . org but they fail to authenticate using chrome / vivaldi / opera / chromium / edge.

The logic behind logins works using firefox.

1 Like

There seem to be intermittent issues with authentication. Please see this infrastructure ticket for more information:

https://pagure.io/fedora-infrastructure/issue/9990#comment-745972

It doesn’t seem to be a browser related issue—you’re probably just hitting the right server sometimes and getting through and hitting the wrong one and seeing errors.

1 Like

Clearing the local storage and cookies, seems to fix the problem most of the times.

1 Like

I have another issue… What is happening is:
0- Open a browser window in “pornmode”
1- Open ask(dot)fedoraproject(dot)org
2- Press Login button
3- I am taken to a id(dot)fedoraproject(dot)org page that requires BASICAUTH, where my user+ PWD or email+PWD DOES NOT WORK. (URL== https://id.fedoraproject.org/login/gssapi/negotiate?ipsilon_transaction_id=xxxxxxxxxxxxxxxxx)
id.fedoraproject
4- Press Cancel on basicauth popup
5- The id page then loads (with some FOnt issues), and I can login with user and pass.

The problem is in step 3. It should not exist, so some server configuration is requesting for Basicauth level permissions that shouldn’t be. To whom can we address this?!

The ID login page with the borked Fonts looks like this

What browser are you using etc.? I’ve tried with Chromium/Chrome/Firefox and do not see an additional login window as you do. Do you have any security extensions installed? What does this secure mode that you are using do?

I don’t get the page with bad fonts either. It looks like your browser is preventing the style-sheet from being loaded perhaps. The page source, for example contains:

 <link href="https://apps.fedoraproject.org/global/fedora-bootstrap-1.5.0/fedora-bootstrap.min.css" rel="stylesheet">

Please check your browser/secure mode to see what’s causing this.

Mmmmm… guess you are right… My company IT is running the browser configuration so they must be doing something weird for unkown ID providers, also supported on a PKI card… on every other computer here @home it is working as intended…

Disregard my last two messages, then. From my just installed fedora 34 it defaults back to the other bad gateway error, but the rest is ok.

Many thxs!
J

1 Like

No worries. Yes, work laptops where the corp manages various things under a security policy tend to have multiple issues with things like this. Not much we can do there, unfortunately.