Audio output problem in Fedora 34 (can't level)

I installed Fedora 34 a few weeks a ago. At first the audio output was extremely loud so I decreased the system volume to around 2% which is still very loud. So I also lowered the volume a lot volume levels of every single app.

After some questions on Reddit I tried Alsamixer and Pavucontrol but unfortunately it doesn’t seem to help. On all apps I am not able to decrease or increase the audio in different levels, it’s just audio on or off. And it looks like the Master Mixer is not reacting or doing anything sometimes.

I am using an Asus Zenbook Pro 15 UX550V.

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 05)
00:01.0 PCI bridge: Intel Corporation 6th-10th Gen Core Processor PCIe Controller (x16) (rev 05)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 630 (rev 04)
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 05)
00:14.0 USB controller: Intel Corporation 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Thermal Subsystem (rev 31)
00:15.0 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Serial IO I2C Controller #0 (rev 31)
00:15.1 Signal processing controller: Intel Corporation 100 Series/C230 Series Chipset Family Serial IO I2C Controller #1 (rev 31)
00:16.0 Communication controller: Intel Corporation 100 Series/C230 Series Chipset Family MEI Controller #1 (rev 31)
00:1c.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #1 (rev f1)
00:1c.2 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #3 (rev f1)
00:1c.4 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #5 (rev f1)
00:1d.0 PCI bridge: Intel Corporation 100 Series/C230 Series Chipset Family PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation HM175 Chipset LPC/eSPI Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation 100 Series/C230 Series Chipset Family Power Management Controller (rev 31)
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
00:1f.4 SMBus: Intel Corporation 100 Series/C230 Series Chipset Family SMBus (rev 31)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)
02:00.0 Unassigned class [ff00]: Alcor Micro AU6621 PCI-E Flash card reader controller
03:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
6f:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller SM961/PM961/SM963

If there are any information I should provide please let me know!

still trying to figure our what’s going on. I also made a comment on Pipewire’s Gitlab and hope someone can help me right there.

Since a current update I see that Alsamixer doesn’t have any control anymore when using Pipewire. Selecting the sound card doesn’t make a difference. The volume mixer is not working at all.

Screenshot from 2021-06-30 23-17-16

In your search for an answer, did you stumble upon this suggestion in the Manjaro forum?

No guarantees it’ll work, but it might be worth a try…

1 Like

thank you, I will give it a try. This post didn’t come up in my search!

1 Like

I found the solution probably. A friend of mine found out that the ProAudio Profile in PulseAudio (pavucontrol) were working but in Carla the sound card is not shown. It looks like a problem with the main board or sound chip that causes the problem.

He wrote a shell script that enables the ProAudio profile and the I added this to the startup apps

#!/bin/bash
pactl set-card-profile alsa_card.pci-0000_00_1f.3 pro-audio

Then I did a bit more digging into the actual hardware problem and it looks like several people had the same issues installing linux (Ubuntu in this case)

So I tried this

Ok, this issue can be fixed by modified pulseaudio instead of the kernel. Will mark this as fixed. For anyone else coming across this having the same issue please add:

> [Element Master]
> switch = mute
> volume = ignore

before the PCM settings block in “/usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common”

and it seems like it’s working now even after disabling the startup ProAudio profile and switching to Analog Stereo Output which was not working before

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.