Audio Problems in Fedora 34 - No sound in one headphone channel

Hello, I’m new to fedora- I just installed it on my ASUS Zenbook UX305C laptop and I’m having problems with the audio driver.

When I connect my computer over bluetooth or HDMI I have fine sound in both channels, and I believe the sound is fine over the laptop speakers though it’s hard to discern stereo over those.

However when I connect my headphones I get fine sound in the left channel and sort of soft harsh noise in the right channel. The noise begins when I start playing audio and stops a couple seconds after the audio does. On top of this, the computer has a hard time accessing the built-in microphone on my computer, which outputs the sound as very quiet and noisy, according to people I zoom with. I jus tried using my Zoom H1n as a DAC and the sound on my headphones works fine so it seems like it’s just ALSA or PipeWIre having a problem with my laptop’s built-in audio IC? Any Ideas?

aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC255 Analog [ALC255 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Let me know if you need outputs or logs from anything else.

What headphones do you use (brand & model), how are they connected (do you use a extension)?

I just would guess and say, from your description, there is a miss-match because of the connectors.

What connector type are you using:

Thanks for the reply!

The headphones are Audio-technica ATH-M50Xs, but I also had this problem just using a 3.5mm jack to plug the computer into my amplifier. So I’m just plugging the headphones’ 3.5mm jack into the 3.5mm hole on the side of the computer. I also used the headphones on this computer before when it had Windows installed on it with no problem. Plus that wouldn’t explain the problems with the laptop’s built-in mic?

OK so I have a bootable usb with Ubuntu 18.04 on it which I used to boot the computer and the same thing is happening? So perhaps it’s a hardware or firmware problem? But like I said this didn’t happen before when the laptop was running WIndows?

Yes it seams to be, that out of the box your Jack and the connector not work perfectly … a better headphone generally not comes attached with mic on the cable. So your jack has two black stripes? right ?

But the connector on you laptop has a combination of mic and headphone, means you need 3 stripes on your jack to have mic, ground, left and a right channel. This could explain the unbalanced stereo sound you hear.

I belief a cable or jack, who divides the mic from the headphone, is what you need.
Windows might have a driver who divides the channels automatically.

This would also explain the not working internal mic. Because of the jack you connect, it might shorten the mic.

Just see link above I posted on my first answer.

I am guessing from what I see that you have the 3 barrel connector and not the 4 barrel connector on the cable. The 4 barrel keeps the mic and headphones separate but the 3 barrel does not.

4 barrel —> common - mic - right - left
3 barrel —? common - right - left
are the normal configs. the plug is the same length normally but using a 3 barrel plug in a 4 barrel jack shorts out the mic & one headphone to a common value.
Most modern laptops have a single (4 barrel) headphone jack and earlier ones used 2 jacks, one (3 barrel) for headphone and one for mic.
Shorting out the mic in the headphone jack does explain the built-in mic having problems.

I see what you’re saying, it is an unbalanced stereo connection with no mic, is there any way to disable the headphone jack mic in software? Because I assume that’s what was going on in windows?

I’m looking at the link you shared and it seems like if you put a 3-connector jack into the 4-connector socket, the mic connection is shorted to ground and not to the left channel or anything. Also I just checked with an audio test video and my left ear is definitely getting the left channel.

Also my mic doesn’t work whether or not the headphones are plugged in.

I’ll see if I can find a headphone with a mic in the jack and see if that changes anything.

I would first try with an adapter like this: