Authentication is required to update software via XRDP

Hello, I just installed Fedora 33 Silverblue. I layered in XRDP (because I have not learned to like Gnome-Remote-Desktop yet) and was able to connect right away, but the system quite often requires re-authentication because of software updates. I am not attempting to update the software when this dialog pops up:reauth.

Anyone else seen this? Is there a way to make it stop?

1 Like

GNOME Software > ☰ > Update Preferences:

  • Automatic Updates > Switch off
  • Automatic Update Notifications > Switch off

See also: Fedora 31 Disable Autoupdate - #2 by davidva

Set as advised, but has not corrected the problem. I will explore related settings where I can find them.

It may disappear when you install the cached updates once or flush the PackageKit cache.

The problem still exists. Here is what I set:
updates

I also get an authentication request “to access the PC/SC daemon”. If you have anymore suggestion of how to make all these authentication requests go away, I’m open to it.

Thanks!

1 Like

pcsc

Actually, this time it’s a different service:
https://fedoraproject.org/wiki/Changes/PcscAccessControl

Do you need that service?
If not, you can try to remove its packages.

Mar 09 14:57:53 silverblue33 systemd[1]: Stopped PC/SC Smart Card Daemon.

Nice. Thanks!

1 Like