Autologin without ANY password prompt

hello

i want autologin, i have it set as such in:

settings -> startup and shutdown -> login screen (SDDM) -> behavior -> automatically login box is checked with my username and plasma x11

this should be enough, no? well. it does autologin but kwallet prompts for password and will not connect to wifi otherwise. i did a search for this and came up with some different solutions, none worked so here i am.

This is what i have done according to guides and forum posts i found but didn’t solve my issue:
i tried:
firs this Kded5 asks for kdewallet password

sudo nano /etc/pam.d/sddm

auth optional pam_kwallet5.so
session optional pam_kwallet5.so auto_start

so my sddm looks like this:
Screenshot_20210809_132600

i have tried this in “settings → connections → all user may connect to this network checked”.

But upon booting into desktop i get this KDE wallet prompt:
Screenshot_20210809_080158

1 Like

Check the output:

sudo cat /etc/NetworkManager/system-connections/WIFI_CON_NAME.nmconnection
[premier69@premier69-pc ~]$ sudo cat /etc/NetworkManager/system-connections/WIFI_CON_NAME.nmconnection
[sudo] password for premier69: 
cat: /etc/NetworkManager/system-connections/WIFI_CON_NAME.nmconnection: No such file or directory
[premier69@premier69-pc ~]$ 

I think that WIFI_CON_NAME was supposed to be replaced by the name of whatever file is located in that directory.

1 Like

[premier69@premier69-pc ~]$ sudo cat /etc/NetworkManager/system-connections/something secret.nmconnection [connection]
id=something secret
uuid=something secret
type=wifi
permissions=

[wifi]
mac-address-blacklist=
mode=infrastructure
ssid=something secret

[wifi-security]
key-mgmt=wpa-psk
psk-flags=1

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

[proxy]
[premier69@premier69-pc ~]$

1 Like
nmcli connection show
nmcli connection modify id "WIFI_CON_NAME" \
    wifi-sec.psk "WIFI_CON_PASSWD" wifi-sec.psk-flags ""

nm-settings-nmcli: NetworkManager Reference Manual

I’m sorry, i didn’t understand your comment, what is it I’m supposed to do? i checked the link you reffered to but it might as well be in another language, and for me it is :frowning:

Copy-paste the commands to the terminal and run it with the following modification:

  • Replace WIFI_CON_NAME with the connection name given by the first line.
  • Replace WIFI_CON_PASSWD with your Wi-Fi password.