Automatic login fedora 34

Hello partners.
I have a question with fedora 34.

In version 33 I remember that the automatic login was for when the pc was turned on, then if it was blocked or suspended it asked to enter the password.

Now in version 34 it is the other way around. The configuration I have activated the automatic login but it always asks me to enter a password, without considering that a small window appears and not as it did in version 33.

This is for the same fedora or does it have to do with the version of the gnome 40?

With gnome
settings —> users —> user —> auto login (button)

I said that I already have it activated but it does not work

@dequixs : I’m at opposite situation to you and been searching for solution. I’ve never turn on Automatic Login, it worked fine until yesterday. After I reinstalled gpu kernel, installed ipv6toolkit and thc-ipv6, Auto-login suddenly work without being enabled (button in setting at off position but it logins automatically after suspend).

Suspend and hibernate are not the same as reboot.
If you are logged in when you suspend then you will be logged in when you resume.

If instead you do a restart or power off then on it looks at the settings to choose an automatic login if that is set.

Hi there.

I already solved my problem. by default lightdm had been installed as display manager.

Following the instructions on this page I was able to switch to GDM and so the automatic login works.

https://www.if-not-true-then-false.com/2018/fedora-switch-display-manager/

1 Like