Automatic passwordless login in Gnome 43.0

I’ve set up automatic login in the settings but this feature seems useless because it bypasses the screen where you have to press enter or click your username but still asks for password. On Ubuntu using Gnome I did not have this problem. How do I auto login without having to provide the password?
Screenshot from 2022-11-27 18-02-10

If you use the settings for auto login in gnome you also need to use GDM to log in. Otherwise the setting not works.

Sorry, I don’t understand what you mean. Do you know the answer to my question?

Can you please run this command in the terminal:

systemctl status gdm to see if you use gdm to log in to your system.

Please post the output of your command as pre-formatted </> text here.

Yes, I do use gdm. If you read carefully my question you will know that I said I do use Gnome. If you’re still not convinced here’s the result of systemctl status gdm

systemctl status gdm
● gdm.service - GNOME Display Manager
     Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; preset: enabled)
     Active: active (running) since Mon 2022-11-28 02:52:12 CET; 1min 2s ago
   Main PID: 1148 (gdm)
      Tasks: 3 (limit: 19056)
     Memory: 5.8M
        CPU: 65ms
     CGroup: /system.slice/gdm.service
             └─1148 /usr/sbin/gdm

Nov 28 02:52:12 fedora systemd[1]: Starting gdm.service - GNOME Display Manager...
Nov 28 02:52:12 fedora systemd[1]: Started gdm.service - GNOME Display Manager.

It’s asking for a password for your keyring or disk encryption if you set that up.
See, https://gitlab.gnome.org/GNOME/gdm/-/issues/701

If it’s the keyring password you can install seahorse and should be able to change the login password to blank.

Thanks

I saw this, but even if you use gnome you not really need to use gdm, you can for example also use lightdm or similar.
But if you do so, you not have all settings available you can set in gnome settings. That’s why I asked :wink:

I don’t want to be rude in any way but it’s always been clear on forums like this that if you know the answer to a question and want to share it then you answer, if you don’t know the answer - you don’t.

Did you install seahorse and delete the keyring login password ?

Settings - Privacy - Automatically lock screen - Cancel

You also did have this issue on Ubuntu, because that aspect works the same there. During login with the login screen, the login keyring also is automatically unlocked. If you automatically login, that keyring is not automatically unlocked. To avoid having to enter a password to unlock the keyring, you can set it to blank as Joe indicated. The difference with Ubuntu is that in Fedora, seahorse (“Passwords and keys”) is not by default installed.

I did not say I did and in fact I did not have this issue on Ubuntu. On Ubuntu, you just go the the settings and tick a checkbox to automatically login after boot and it works but on Fedora it does not.

No, I didn’t install any seahorse (I don’t know that that it) and I didn’t delete any keyring login password. I have a fresh install and just toggled automatic login in Users settings.

https://help.gnome.org/admin/system-admin-guide/stable/login-automatic.html.en

If you enable automatic login in Users settingsin UI, this :point_down: is already set.

[daemon]
AutomaticLoginEnable=True
AutomaticLogin=username

Type while click on Activities >Passwords
Do you get Application linked to this ? Seahorse is linked to this … that’s what @grumpey asked.
If you have a login stored with a different password then this will make the password login pop up.

If you delete the basic key-ring you create a new one while log in the first time. After it should not ask you again. With a key-ring you use the password once and every-time if you get asked to use your credentials gnome takes them from the key-ring it stored there. If it is not the same as you use for the user you make auto login it will not work.

If you do not wish to install seahorse, you can also eliminate the password for the keyring by deleting ~/.local/share/keyrings/*.keyring. On next login, the system will ask to set a password: then provide a blank one.