Battery charge indicator broken on certain ASUS motherboards, automatic suspend doesn't work

Problem

On certain ASUS motherboards, the battery charge indicator might not work properly. It is either stuck (showing the same value all the time), or behaves erratically. Automatic suspend (e.g. when closing a laptop lid) might also be broken, even though manual suspend does work.

Cause

The origin is connected to the asus_ec_sensors driver in the Linux kernel, which gets sensor readings from some ASUS motherboards (acpi-related). The exact origin remains to be identified. The problem appears since kernel 5.19.4 on systems using asus_ec_sensors.

Related Issues

Bugzilla report: #2121844
Upstream kernel discussion: Issue in asus_ec_sensors in Fedora installations and other distributions

Related topics in Ask Fedora elaborating the issue:
Battery indicator not working properly | ASUS TUF Gaming A15 FA506IH
Battery status problem in F36
The battery indicator stop functioning properly | ASUSTeK FA506IV
Power indicator state not working in kernel 19.4-200

Solution

6 Likes

The problem has been fixed in kernel-5.19.9. Please update your system as usual, and the problem will be resolved.

If you’ve enabled a workaround for this issue, as documented below, please don’t forget to remove it!

Reverting the workaround
(for those who enabled it before the fixed kernel was available)

Please follow these steps to disable the temporary workaround and return your system to the default state:

sudo rm /etc/modprobe.d/asus_ec_sensors-blacklist.conf
sudo grubby --remove-args='rdblacklist=asus_ec_sensors' --update-kernel=ALL

For rpm-ostree-based systems, skip the last line.