Black popup boxes

I currently run F32 WS with Gnome. However, this has been a problem for me back through several prior versions of Fedora WS with Gnome.

Every time my mouse cursor hovers over any sort of link, button, or icon, in any application, a black popup box appears telling me all about the link, button, or icon. I don’t want or need these and they usually pop up over something I’m trying to read.

I’ve grepped the schemas to see if there is a key I can set to turn them off, but was not successful. Can someone please tell me how I can turn these popups off?

Thanks in advance for your help with this.

Have a Great Day!

Pat

As I re-read this post I see that I should have written more.

I did find several keys in the schemas that are for controlling pop-ups, but according the “description” text with these keys there do not seem to be any that control these link description pop-ups. Have I missed something? Is there some other way to turn off these link description pop-ups?

1 Like

Probably you should describe a method to reproduce the issue, list the apps affected by this problem, as well as provide some sort of diagnostics:

set | grep -e ^XDG_; lspci | grep -i -e vga -e hdmi \
| while read -r DEV_ID SKIP; do lspci -k -n -n -s ${DEV_ID}; done

This is reproducible on lots of applications. For instance open nautilus and place the mouse cursor over any of the directories in the side bar. For instance (Documents) and a pop-up box will appear that says “/home/user/Documents”. Open Text Editor and place the mouse cursor over arrow on the Open button. You’ll get a pop-up that says “Open a recently used file”.

Here is the result for the commands you provided:

$ set | grep -e ^XDG_; lspci | grep -i -e vga -e hdmi \

| while read -r DEV_ID SKIP; do lspci -k -n -n -s ${DEV_ID}; done
XDG_CURRENT_DESKTOP=GNOME
XDG_DATA_DIRS=/home/table1pc2/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/
XDG_MENU_PREFIX=gnome-
XDG_RUNTIME_DIR=/run/user/1000
XDG_SESSION_CLASS=user
XDG_SESSION_DESKTOP=gnome
XDG_SESSION_TYPE=wayland
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri [Radeon R7 Graphics] [1002:130f]
Subsystem: Lenovo Device [17aa:36a0]
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu
00:01.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Kaveri HDMI/DP Audio Controller [1002:1308]
Subsystem: Lenovo Device [17aa:36a0]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

I believe this is a “feature” I’m trying to turn off rather than a bug.

Thanks for your help.

1 Like

https://bbs.archlinux.org/viewtopic.php?pid=1750829#p1750829

Thanks that helped a lot, but there seems to be one more I need to set somewhere. For instance open Firefox and browse this page:

Put your mouse cursor over the picture of the memory device. and a big pop-up will appear.

1 Like

Yes, I can see a “alt”-Textbox slightly opaque with a white text " Intel Optane Memory 16GB MEMPEK1W016GAH, PCI-e NVMe M.2 HP PN 925507" - does it look all blacked out for you?

Cheers

https://www.ghacks.net/2019/05/24/firefox-69-userchrome-css-and-usercontent-css-disabled-by-default/

Probably you should rename the thread to: Disable GTK and Firefox tooltips

The boxes were completely opaque black with white text.

Thanks! Now it seems like all the “tool tips” are turned off. I really appreciate your help with this.

I agree on the title now that I know what is involved, but I don’t see a way to change the title.

Have a Great Day!

1 Like