Blackground with newer kernel

Hi,

I did the command line upgrade F31 5.6.8-200.fc31-x86_64 -> F32 5.6.10-300.fc32.x86_64, no problems been reported.
After log in, I shortly see the desktop background from 31, but then I have a black desktop background.
When clicking on the top left ‘Activities (Aktivitäten)’ Button, I do see the correct background, but darker as usual. When leaving the Activities the background is black again.
Under Settings -> Info: Gnome 3.36.2 and X11 Window Manager is reported.

When booting the previous F31, ‘uname -a’ reports the previous kernel, but Info reports Fedora 32 with Gnome 3.36.2 and the desktiop is the same as in the upgraded F32.

I am using a Geforce GTX660.

Thanks for suggestions!

Have you got any gnome-shell extensions installed from extensions.gnome.org, by any chance? They might need to be updated (or removed). Try disabling the extensions and see if the problem goes away. If it does, turn them back on one by one to find the culprit.

What happens if you try to choose another background? Is everything still black?

For me the fact that it works with an older kernel highly suggest a bug with radeon driver (I don’t think nvidia-drivers can be installed on this old version with Fedora 32).

So I would directl go to: https://koji.fedoraproject.org/koji/packageinfo?packageID=8

begin to search kernel versions… and download in a directory:

oh, wait: between F31 5.6.8-200.fc31-x86_64 -> F32 5.6.10-300.fc32.x86_64 ?
It is so close…

Now in testing is kernel-5.6.11-300.fc32… you could try that by enabling testing repos.
See https://fedoraproject.org/wiki/QA:Updates_Testing

Ah yeah… except that it is unlikely the newer kernel fix your problem (but it is worth a try)…

So was saying … in an empty directory download:
https://kojipkgs.fedoraproject.org//packages/kernel/5.6.8/300.fc32/x86_64/kernel-5.6.8-300.fc32.x86_64.rpm
https://kojipkgs.fedoraproject.org//packages/kernel/5.6.8/300.fc32/x86_64/kernel-modules-5.6.8-300.fc32.x86_64.rpm
and then go to this directory in a terminal and then:
sudo dnf install kernel-*.rpm

The idea being to try different versions to find the first that introduce the problem.

In all likelihood there are more kernel subpackages installed, it would be safer to
rpm -qa | grep kernel | sort
to figure out which are needed.

If the kernel-headers package (which is separate from the kernel) is required by something, that’s going to complicate things, there can be only one version installed on the system.

By the way, you can feed dnf URLs of packages, e.g.
dnf install https://kojipkgs.fedoraproject.org//packages/kernel/5.6.11/300.fc32/x86_64/kernel-5.6.11-300.fc32.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/kernel/5.6.11/300.fc32/x86_64/kernel-core-5.6.11-300.fc32.x86_64.rpm https://kojipkgs.fedoraproject.org//packages/kernel/5.6.11/300.fc32/x86_64/kernel-modules-5.6.11-300.fc32.x86_64.rpm

I choose a different background, but the black background is still present, except when clicking on ‘activities’ as described before.
What will be way to disable the gnome-shell extensions?

I have installed a Nvidia Geforce GTX660, does it use a Radeon driver?

The problem came with the F32 upgrade, F31 5.6.8-300 worked well and stable.
Your and alexpi suggestion is to try the coming kernel?

Two things are surprising for me:
Even when selection an older F31 kernell, the new desktop appears,

X11 is t the Windows Manager, isn’t Wayland the standard one for current Gnome?

If you have “Tweaks” or “Extensions” installed, you can use the toggle at the top of the window to turn all extensions off, or use the individual toggles next to each extension. I’d say you start by disabling everything.
After each change, it might be a good idea to restart the shell, Alt+F2 and in the prompt that appears, type r and hit enter.

Your desktop environment is independent of the kernel.

In all likelihood you’ve switched to Xorg when you installed the nVidia drivers.

Let’s verify!
What is the output of:
lsmod | grep video
?

In the top-middle I just see date and time, a click on it shows the calender (and no notifications). At the top right there are the three stanrd symbols for network, volume and on/off.

Thanks for the Xorg hint!
akmod-nvidia
kmod-nvidia-5.6.10-300.fc32.x86_64
kmod-nvidia-5.6.7-200.fc31.x86_64
kmod-nvidia-5.6.8-200.fc31.x86_64
nvidia-settings
xorg-x11-drv-nividia
xorg-x11-drv-nvidia-libs
are installed

the output is:
video 53248 0

Oh… then it looks like you are indeed using proprietary drivers.

Wayland is automatically disabled because of a compatibility problem between nvidia-drivers and gdm.

Part of the problem is because it is developed externally to the kernel, and device drivers have not a fixed binary interface like in Windows, nvidia drivers just cannot follows with kernel development. And I will suggest you ‘pin’ an older kernel… to avoid kernel updates… I need to look how to do it…

Looks like you add a line like:
excludepkgs kernel-5.6.8-200.fc31-x86_64
to /etc/dnf/dnf.conf file.

and then remove other more recent kernels…
Yeah… honestly it seems weird to do.

Maybe for this kind of older Nvidia cards… nouveau would do a nice job.
That would be NVE0 column on:
https://nouveau.freedesktop.org/wiki/FeatureMatrix/

“Tweaks” and “Extensions” are GNOME applications; either will do.
Screenshot from 2020-05-10 17-24-28

This is from “Tweaks”:

and this from “Extensions”:

Their interfaces are quite similar, but in Tweaks you have to select the Extensions pane first (not confusing at all, is it?). Both programs have a toggle for all of the extensions on the top right and individual toggles next to each extension.

1 Like

Both are not installed, I do not get a search result.

I remember problems with an electronics layout program using the nouveau drivers and that was the reason to install the Nvidia drivers.

I have checked with dnfdragora:
xorg-x11-drv-nouveau
is still installed

I don’t think we can call xorg-x11-drv-nouveau the nouveau driver.
This is the mesa drivers for OpenGL display.

The nouveau driver is an other driver, inside the kernel. And when using the nvidia-drivers, noueau is not used at all, neither the one in the kernel, neither xorg-x11-drv-nouveau… as far as I know. To be honest… it is a bit unclear to me how much is done by the kernel part and which in the xorg-x11-drv-nouveau part… I think framebuffer is made avaiable by the kernel part. More precisely… drm (direct rendering manager) is done by the kernel… and drm use the nouveau driver in the kernel… I think.

I now see GTX 660 is supported by latest nvidia driver 440.82.

The Nvidia setting tools shows:

grafik

Does the system works fine for you with kernel-5.6.8-200.fc31-x86_64 ?

My recommendation if yes, would to keep it until next release of the nvidia-drivers.

With kernel-5.6.8-200.fc31-x86_64 I have the same ‘blackground’.

I can use the F32. Programs started as usual as far as I have tested it.
I guess I had Gnome 3.34.6 before, not knowing if that made any difference.

I agree to wait a bit and see if coming updates will solve the problem.
A terminal on black background is not perfect, but can be used.

I will try an F31 -> F32 upgrade on a Laptop with integrated Haswell graphics and see what happens then.