Blank screen after installing Nvidia driver -- secure boot was the culprit

I installed nvidia drivers as instructed
here
Installation went fine.
after reboot I got error on screen
Nvidia Kernel Modules missing, Pulling back to nouveau
& then got blank screen
OS: fedora 30
Laptop: acer nitro AN515-52-593F , 1050 Nvidia graphics card

I’m able to login by replacing quiet by nomodest at kernel boot.
how to resolve “Nvidia Kernel Modules missing” error?

Check /etc/modprobe.d/ for nouveau blacklist file. If found, delete the blacklist file. Also remove /etc/x11/xorg.conf which probably has entries for the nvidia driver. Also, make backups before deleting.

You can also try dnf remove xorg-x11-drv-nvidia\* or sudo NVIDIA-Linux-x86_64-418.56.run --uninstall

But I want to resolve “Nvidia Kernel Modules missing” error

Hi @sholisj! Welcome to Ask Fedora! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

With NVidia driver kernel modules are recompiled for each new kernel on a reboot (also this recompilation slows your boot – but only once for each new kernel version – this is normal).

It looks like this compilation failed in your case.

When you this black screen situation you can also switch to text console (so-called tty) with [Crtl]-[Alt]-[F3] (or F4, 5 or 6) and login with your username. After that you can do some troubleshooting – without the need to reboot first.

Please post here output of

sudo dnf list installed '*nvidia*'
sudo akmods

it could be useful.

akmods is the command responsible for rebuilding kernel modules for NVidia driver.

To force it to try to rebuild the modules again use

sudo akmods --force

If it fails again, it’ll tell you so – and it’ll give you the name of the log file containing all the details of the rebuild process.

From my personal experience, when I’ve encountered black screen as you did (that happened to me sometimes, but not that often) – almost always it was enough to manually run sudo akmods --force and the modules were rebuilt successfully. On a more rare occasions manual rebuilds failed as well – in such a case I had to wait for driver package update that resolved the problem. Usually I had to wait no more than a couple of days for such an update (and usually it appeared in testing repository even sooner). Such a thing happened to me two or three times during several (five or more) years I’ve been using proprietary NVidia drivers.

2 Likes

Screenshot%20from%202019-09-19%2022-48-15

Did you install according the link that you did left the package akmod-nvidia sudo dnf install akmod-nvidia? I dont see it between the listed packages

https://rpmfusion.org/Howto/NVIDIA#Current_GeForce.2FQuadro.2FTesla
https://rpmfind.net/linux/RPM/rpmfusion/nonfree/fedora/updates/30/x86_64/a/akmod-nvidia-430.40-1.fc30.x86_64.html

Just asking i dont know too much about it.

@xtymScreenshot%20from%202019-09-19%2023-40-14

@nightromantic on login screen, Ctrl+Alt+F3 tured screen to blank

Sorry i didnt see it was in the first picture…:sweat_smile:

I removed rd.driver.blaclist=nouveau from grub menu(by pressing “e” during boot )& error msg “Nvidia Kernel Modules missing” didn’t came on screen & fedora is working fine.
Using intel graphics at present

If I removed modprobe.blacklist=nouveau , also with rd.driver.blacklist=nouveau I’m again getting black screen
removing everything until “quiet” also gives me blank screen
So I get proper screen after login on replacing “quiet” by nomodeset & removing other argumemts after it

& by meoving only " rd.driver.blacklist=nouveau"

You can know it looking in the setting of gnome

or with the command glxinfo -B

I think the problem was with secure boot, I turned it off & everything works fine

3 Likes

You’re absolutely right, nvidia’s drivers don’t work with secure boot enabled. Nvidia’s kernel modules are built on your system and aren’t signed, and secure boot prohibits loading them. It’s in the How-to in fact, you must have missed it:

https://rpmfusion.org/Howto/NVIDIA#Secure_Boot

Secure Boot
Secure Boot currently blocks the kernel from loading the NVIDIA driver. It must be disabled before booting the OS.

There’s also this article in FedoraMagazine about Nvidia’s driver installation with quite a few details and useful bits – and with some useful info in the comments too. Article is for older version of Fedora, but is still relevant.


I’m glad you’ve solved your issue, please mark your own post as a solution so that others with the same problem can easily find it.

2 Likes

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.