Blank screen after login, after fedora 32 upgrade

Hello I’m a newbie to linux and fedora, so please excuse me if I do not use the correct terminology while describing my issue.
I did the upgrade from 31 to 32 and all seems to have upgraded well. So after install it seem to boot ok and I arrived at the login screen (as I was when I was on 31). After logging in, the screen went black and stayed that way. A couple of times the screen will flicker, or some distorted image will show the back to black screen. I am able to move my mouse pointer as it will show on the screen. The OS or gnome seems to be running and functioning as I can move the mouse to the top corners of my screen and click on the area, and some distortion of the screen occurs then goes back to grey or black. If I press CRTL-ALT-F3 , it will take me back to the login screen in which I am able to see the login prompt and shut down the machine properly. But soon as I login again the screen goes blank again.
I can reboot with the previous 31 kernel fine ( in which I’m typing here now ). So seems to be some sort of video issue after logging into gnome.
I believe I’m running the generic driver Nouveau.
I have an old HP Pavillion desktop machine with 4GB of ram. Intel pentium. I typed the linux command to see my video card info and I have an old NVIDIA GeForce 7100 / nForce 630i graphic card.

So any ideas and help would be appreciated.

Are you running a 32-bit system if so F32 can’t support it

You could also try to get the Proprietary Nevidea Driver from the RPM Fusion Repo. (As I don’t have Nevdia I don’t know how to do that but its worth a shot)

One last thing what Model do you have?

P.S. this should be filed on Upgradeing Fedora

No, I am running the 64 bit system

ok I would try getting the BLOB drivers then, you can probibly find a guide on the internut

it is : Intel® Pentium® Dual CPU E2200 @ 2.20GHz × 2

get the proprity drivers, thats the only thing I can think of

Here is a guide to get the drivers

Try to see if changing the display server works from the default Wayland or Xorg

1 Like

Sorry for the late reply, caught up with work this past weekend. Thanks for the link to the guide.
I have not installed the driver due to the version on my graphic card seems to be out dated as it is a Legacy GeForce 6 card and is EOL which has no more nvidia updates. The last support version is Fedora 27. The latest supported driver version for my card is 304.xx. The oldest version to be installed from the RPM instructions is Legacy 8/9 versions which is 340.xx. So not sure as to what could support the card. If version 304.xx is able to be installed from somewhere or even if 304.xx could run in Fedora 31 and 32.

Sorry for the delay,
Thanks for the info. I did try changing the display server from Wayland to Xorg. It did not work. Still same on both

1 Like

Had similar problem with fedora 31 update.
After entering the user credentials gnome froze on a gray screen.

Googled, managed to switch to terminal.

In my case I commented out the ssh agent lines in ky bash_profile. It seems an incompatibility between the way terminal and gnome handle ssh keys load in agent.

If this are also your symptoms, I suggest to try and make a copy of your bash_profile file, an try with a very basic bash_profile.

Hope it helps.

Hello ionescu77. thanks for info. I did check my bash_profile file. It is the basic file. Just points to the bashrc file. Looked at the bashrc file. Not really knowing what I’m looking at, but I did not find any references to ssh agents keys, or ssh…etc. So don’t think that is an issue.

Correction on the initial issue post. It was not upgraded to Fedora 32. The issue occured after a kernel update. So it is still running Fedora 31. The problem occurred after the update to kernel (5.6.7-200.fc31.x86_64). When I select the previous kernel (5.5.17-200.fc31.x86_64), no issue.

I would suggest you reboot with the Fedora 32 kernel… Try to login… experience the black screen a bit… Use Ctrl-F3… or Ctrl-F2 or Ctrl-F1… to return to the login screen… reboot with Fedora 31 kernel.

And then you could send your logs to fpaste web site, with:
journalctl -b -1 -p4 --no-pager | fpaste
the -b -1 would means the session before the current one,
-p4 would limit to error messages
–no-pager would make sure it would not wait for you to press keys
| fpaste would send to paste site for 24h the contents…
that should result in a link that you can first check yourself in the browser to make sure it does not contains something you would not wish to publish

Then you could paste the link here.

thanks for the info pauld. Here is the link:
https://paste.centos.org/view/488293d1

Does not begin with kernel command line.

– Logs begin at Mon 2020-02-03 11:31:12 MST, end at Wed 2020-05-06 15:22:05 MDT. –
Copying what seems most interesting lines here:

  • May 06 09:06:41 localhost.localdomain kernel: ACPI BIOS Warning (bug): Optional FADT field Pm2ControlBlock has valid Length but zero Address: 0x0000000000000000/0x1 (20200110/tbfadt-615)

  • May 06 09:06:41 localhost.localdomain kernel: core: PEBS disabled due to CPU errata

  • May 06 09:06:43 localhost.localdomain kernel: nouveau 0000:00:10.0: DRM: TMDS table script pointers not stubbed

  • May 06 09:06:44 localhost.localdomain systemd-vconsole-setup[396]: KD_FONT_OP_GET failed while trying to get the font metadata: Invalid argument

  • May 06 09:06:44 localhost.localdomain systemd-vconsole-setup[396]: Fonts will not be copied to remaining consoles

  • May 06 15:07:13 localhost.localdomain systemd[1]: abrt-oops.service: Failed with result ‘exit-code’.

  • May 06 15:07:35 localhost.localdomain gnome-shell[906]: Failed to initialize accelerated iGPU/dGPU framebuffer sharing: No matching EGL configs

  • May 06 15:07:39 localhost.localdomain dbus-broker-launch[723]: Activation request for ‘org.freedesktop.resolve1’ failed: The systemd unit ‘dbus-org.freedesktop.resolve1.service’ could not be found.

  • ay 06 15:07:50 unknown001fe2553e6e.attlocal.net gnome-shell[906]: Getting invalid resource scale property

  • May 06 15:07:50 unknown001fe2553e6e.attlocal.net gnome-shell[906]: ibus_bus_hello: assertion ‘ibus_bus_is_connected (bus)’ failed

  • May 06 15:07:50 unknown001fe2553e6e.attlocal.net gnome-shell[906]: Error while sending AddMatch() message: The connection is closed

  • May 06 15:07:50 unknown001fe2553e6e.attlocal.net gnome-shell[906]: ibus_bus_call_async: assertion ‘ibus_bus_is_connected (bus)’ failed

  • May 06 15:08:42 unknown001fe2553e6e.attlocal.net gnome-shell[1514]: Failed to initialize accelerated iGPU/dGPU framebuffer sharing: No matching EGL configs

  • May 06 15:08:57 unknown001fe2553e6e.attlocal.net gsd-color[1723]: failed to connect to device: Failed to connect to missing device /org/freedesktop/ColorManager/devices/xrandr_Hewlett_Packard_HP_2310_3CQ0212K74_gdm_42

  • May 06 15:08:58 unknown001fe2553e6e.attlocal.net gnome-shell[906]: Connection to xwayland lost

  • May 06 15:08:58 unknown001fe2553e6e.attlocal.net gnome-session-binary[899]: WARNING: Could not get session class: No such device or address

  • May 06 15:08:58 unknown001fe2553e6e.attlocal.net gnome-session-c[2047]: Failed to restart DBus service: The connection is closed

Investigate https://gitlab.gnome.org/GNOME/mutter/issues/635 “This bug is apparently back again in mutter-3.36.0 as packaged in Fedora 32 beta:”

Might be linked to https://bugzilla.redhat.com/show_bug.cgi?id=1762151

What would be the outpug of “glxinfo|grep GLES” and of “inxi -Gxx” … I think it is ok to run these commands with Fedora 31 kernel.

I ran the first command glxinfo|grep GLES and received this back
Max GLES1 profile version: 1.1
Max GLES[23] profile version: 2.0

not sure what the command syntax is for the second command inxi -Gxx as I received a bash command error