Blank screen on start up after switch to nvidia gpu

my system:
nvidia gtx1650 mobile
Operating System: Fedora Linux 35
KDE Plasma Version: 5.24.4
KDE Frameworks Version: 5.91.0
Qt Version: 5.15.2
Kernel Version: 5.14.10-300.fc35.x86_64 (64-bit)
Graphics Platform: Wayland
Processors: 12 × Intel® Core™ i7-9750H CPU @ 2.60GHz
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
(right now i switched back to intel gpu)

i tried to switch my default gpu to nvidia according to rpmfusion guide
nvidia work for me on x11 but not on wayland and when i set nvidia to my default gpu(sudo nano /etc/X11/xorg.conf.d/nvidia.conf and write Option “PrimaryGPU” “yes”) I dont see my login screen on startup(black), I have to type my password blindly only then it goes to the desktop.
thanks

edit: here is an additional info from journalctl -b

May 10 19:10:50 fedora kernel: nvidia: loading out-of-tree module taints kernel.
May 10 19:10:50 fedora kernel: nvidia: module license 'NVIDIA' taints kernel.
May 10 19:10:50 fedora kernel: Disabling lock debugging due to kernel taint
May 10 19:10:50 fedora kernel: nvidia: module verification failed: signature and/or required key missing - tainting kernel
May 10 19:10:50 fedora kernel: mc: Linux media interface: v0.10
May 10 19:10:50 fedora kernel: mei_me 0000:00:16.0: enabling device (0000 -> 0002)
May 10 19:10:50 fedora kernel: videodev: Linux video capture interface: v2.00
May 10 19:10:50 fedora kernel: nvidia-nvlink: Nvlink Core is being initialized, major device number 507
May 10 19:10:50 fedora kernel: 
May 10 19:10:50 fedora kernel: proc_thermal 0000:00:04.0: enabling device (0000 -> 0002)
May 10 19:10:50 fedora kernel: ACPI: bus type thunderbolt registered
May 10 19:10:50 fedora kernel: nvidia 0000:01:00.0: enabling device (0000 -> 0003)
May 10 19:10:50 fedora kernel: intel_rapl_common: Found RAPL domain package
May 10 19:10:50 fedora kernel: intel_rapl_common: Found RAPL domain dram`Preformatted text`


May 10 19:10:52 fedora systemd[1]: Starting nvidia-powerd service...
May 10 19:10:52 fedora avahi-daemon[893]: Found user 'avahi' (UID 70) and group 'avahi' (GID 70).
May 10 19:10:52 fedora systemd[1]: Starting Authorization Manager...
May 10 19:10:52 fedora systemd[1]: Starting Power Profiles daemon...
May 10 19:10:52 fedora systemd[1]: Starting System Logging Service...
May 10 19:10:52 fedora /usr/bin/nvidia-powerd[905]: nvidia-powerd version:1.0(build 1)
May 10 19:10:52 fedora /usr/bin/nvidia-powerd[905]: SBIOS support not found for NVPCF GET_SUPPORTED function
May 10 19:10:52 fedora /usr/bin/nvidia-powerd[905]: No matching GPU found
May 10 19:10:52 fedora /usr/bin/nvidia-powerd[905]: Failed to initialize RM Client
May 10 19:10:52 fedora systemd[1]: Starting RealtimeKit Scheduling Policy Service...
May 10 19:10:52 fedora systemd[1]: Starting Self Monitoring and Reporting Technology (SMART) Daemon...
May 10 19:10:52 fedora systemd[1]: Condition check resulted in System Security Services Daemon being skipped.
May 10 19:10:52 fedora systemd[1]: Reached target User and Group Name Lookups.
May 10 19:10:52 fedora /usr/sbin/irqbalance[899]: libcap-ng used by "/usr/sbin/irqbalance" failed dropping bounding set due to not having CAP_SETPCAP in capng_apply

May 10 19:10:53 fedora systemd[1]: Condition check resulted in Fallback to nouveau as nvidia did not load being skipped.

Welcome to ask :fedora: @guyc1800

Have you seen this? This gives you might some help even if it was for F34.

i tried now the suggested answer by rockingcat

If you have G-Sync enabled, try adding the command nvidia-settings -a AllowVRR=0 to /etc/sddm/Xsetup . Driver version 470.74 can have some issues with VRR feature.

but on nvidia-settings on “x server display configuration”
i cant see if gsync is enabled , looked it up and as I understood Prime displays means displays that are connected to the igpu so nvidia settings cannot change it.
i had the same problem(PRIME DISPLAYS cannot be controlled…) on my previous distro (on this laptop), so it might be a bios setting? any idea?

the drivers eventually working after dnf update and reboot also i reinstall all the drivers just to make sure everything is fine but still having problem that i dont see my login screen

ended up solving this problem thanks to someone in the community , reinstalled the drivers and set igpu as my default gpu, i will use my nvidia only to run game and outher stuff aka offload render .

in order to preform all of this , update packages and kernel sudo dnf update -y
after this deleting /etc/X11/xorg.conf.d/nvidia.conf will make intel as primary gpu and when I want to run a game just create shortcut to its executable like this:
__NV_PRIME_RENDER_OFFLOAD=1 __VK_LAYER_NV_optimus=NVIDIA_only __GLX_VENDOR_LIBRARY_NAME=nvidia /path/to/game/exe
example to executable /usr/bin/steam

1 Like

I am not 100% certain this will work.

The /etc/X11/xorg.conf.d/nvidia.conf file in its original version (before edits) has a stanza that reads

Section "ServerLayout"
	Identifier "layout"
	Option "AllowNVIDIAGPUScreens"
EndSection

It is my understanding that the Option in that stanza is what allows the nvidia GPU to control both the internal screen and the external screen. IIUC then your fix will only allow the nvidia to control an external screen and not the internal screen.

I may be wrong, so test it to find out for certain.

1 Like

after deleting the file, new nvidia.conf file is generated with this configuration that you sand, I already solved the problem but thanks anyway