Blank screen when booting kernel 5.17.11

Everything is normal when booting back into the previous kernel 5.17.9-200.fc35.x86_64. But 5.17.11-200.fc35.x86_64 turns off the display signal then goes to a blank screen during the boot process, a little while after entering the LUKS passphrase and just before the lightdm login screen would normally be displayed.

The system itself works fine otherwise. Logging in via ssh, systemctl status shows no problems, nvidia-smi shows the proprietary driver is loaded, etc. If rebooting the system via ssh with systemctl reboot, I see the fedora logo on the otherwise blank display momentarily before it reboots, so it’s not like it’s totally not working.

I tried rebooting into the different kernels several times and the results are consistent, 5.17.11 always has this blank screen issue while 5.17.9 works normally. I didn’t have time for more diagnostics so I’m running 5.17.9 for now. Any thoughts on what else to check?

hi fasulia

I had this problem too. As you suspect I think this is the nVidia driver (I was using 510.68.02 from the nVidia website rather than the standard Fedora build - I originally needed this to get the 5.17 kernel working but it gave up when I updated to 5.17.11). My video is working again after I uninstalled the nVidia driver and switched back to nouveau (I am using KDE desktop).

I’m not sure how the interaction between X, Wayland and nVidia works - I clearly need to read up on this but in the meantime, my priority was to switch out nVidia. The uninstall procedure I used is loosely based on

No responsibility accepted for problems resulting, make sure you take backups etc.

Boot into runlevel 3 using the 5.17.9 kernel

Change to root user:
sudo -i

Start nVidia uninstall
nvidia-installer --uninstall

When prompted re restoration of /etc/X11/xorg.conf I responded Yes. Ignore any warnings (what am I supposed to do about them anyway?)

Remove nouveau blacklisting:
either get rid of file /etc/modprobe.d/nouveau-blacklist.conf
or remove ‘blacklist nouveau’ line from /etc/modprobe.d/blacklist.conf

There may be a blacklist clause ‘rd.driver.blacklist=nouveau’ in ‘GRUB_CMDLINE_LINUX=”…”‘ config in
/etc/default/grub. In my case there wasn’t, so I didn’t have to remove it, and by the same token I didn’t have to regenerate GRUB config so did not run

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg
(or grub2-mkconfig -o /boot/grub2/grub.cfg if not using EFI)

I already had the nouveau driver installed but if not:
dnf install xorg-x11-drv-nouveau

Then generate a new initramfs. I am running 5.17.9 while troubleshooting but want to update the 5.17.11 initramfs, so specify the kernel explicitly and don’t use $(uname -r):

mv /boot/initramfs-5.17.11-200.fc35.x86_64.img /boot/initramfs-5.17.11-200.fc35.x86_64-nvidia.img
dracut /boot/initramfs-5.17.11-200.fc35.x86_64.img 5.17.11-200.fc35.x86_64

I did not do this - not required on FC35?
dnf reinstall xorg-* mesa* libglvnd*

Then reboot. Hope this helps

woops didn’t realise there was already a chat going on for this subject. Not the first time a new kernel has broken the driver. Apologies, I’m a noob on this forum.

Thanks for the suggestion. Unfortunately uninstalling the proprietary drivers is not an option for me. I have them installed from the negativo17 repo.

Despite common complaints, this might be the first time a kernel update has caused issues with the display drivers for me.

Btw, I’m running X, not Wayland.

Hi, this should be fixed (the simpledrm change reverted) in kernel 5.17.12, currently in updates-testing.

1 Like

Confirmed, 5.17.12 works just fine. Only 5.17.11 has the issue.