Bluetooth Always ON on Boot

The same issue that was marked as solved but didn’t really get solved happens to me on a new install of Fedora 36, too:

Everytime after reboot, I need to turn off Bluetooth when I don’t want to use it.

I found, bluetooth.service starts very early during boot. I am not used to this behavior, and usually when I turn it off on other systems, it also stays off after reboot.

Not on Fedora 36 (on both Gnome-, and Xfce-DE) on this machine:

$ inxi -Fzxa
System:
  Kernel: 5.18.7-200.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36
    parameters: BOOT_IMAGE=(hd1,gpt7)/vmlinuz-5.18.7-200.fc36.x86_64
    root=UUID=511b4741-ab42-4bd8-9d2b-26b4e6d4d71f ro rootflags=subvol=root
    nomodeset rhgb quiet
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.34 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 2 dm: 1: GDM v: 42.0 2: LightDM v: 1.30.0 note: stopped
    Distro: Fedora release 36 (Thirty Six)
Machine:
  Type: Desktop System: Apple product: iMac11,1 v: 1.0
    serial: <superuser required> Chassis: type: 13 v: Mac-F2268DAE
    serial: <superuser required>
  Mobo: Apple model: Mac-F2268DAE serial: <superuser required> UEFI: Apple
    v: 63.0.0.0.0 date: 06/14/2019
CPU:
  Info: model: Intel Core i7 860 bits: 64 type: MT MCP arch: Nehalem
    gen: core 1 built: 2008-10 process: Intel 45nm family: 6
    model-id: 0x1E (30) stepping: 5 microcode: 0xA
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 1370 high: 1919 min/max: 1197/2794 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1919 2: 1197
    3: 1197 4: 1197 5: 1197 6: 1450 7: 1611 8: 1197 bogomips: 44688
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD RV770/M98L [Mobility Radeon HD 4850] vendor: Apple
    driver: N/A alternate: radeon, amdgpu arch: TeraScale process: TSMC 55-65nm
    built: 2005-13 pcie: gen: 2 speed: 5 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 1002:944a class-ID: 0300
  Device-2: Apple Built-in iSight type: USB driver: uvcvideo
    bus-ID: 2-1.1:3 chip-ID: 05ac:8502 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.2
    compositor: xfwm v: 4.16.1 driver: X: loaded: modesetting,vesa
    unloaded: fbdev,radeon gpu: N/A display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: Unknown-1 mapped: None-1 res: 1920x1080 hz: 60 size: N/A
    modes: 1920x1080
  OpenGL: renderer: llvmpipe (LLVM 14.0.0 128 bits) v: 4.5 Mesa 22.1.2
    direct render: Yes
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
    class-ID: 0403
  Device-2: AMD RV770 HDMI Audio [Radeon HD 4850/4870] vendor: Apple
    driver: snd_hda_intel v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 1002:aa30 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.7-200.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.52 running: yes
Network:
  Device-1: Broadcom NetXtreme BCM5764M Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 02:00.0
    chip-ID: 14e4:1684 class-ID: 0200
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR928X Wireless Network Adapter
    vendor: Apple AirPort Extreme driver: ath9k v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 168c:002a
    class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
Bluetooth:
  Device-1: Apple Built-in Bluetooth 2.0+EDR HCI type: USB driver: btusb
    v: 0.8 bus-ID: 1-1.1.1:5 chip-ID: 05ac:8215 class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 17.73 GiB (1.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST31000528ASQ
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: AP24 scheme: GPT
Partition:
  ID-1: / raw-size: 53.48 GiB size: 53.48 GiB (100.00%)
    used: 17.4 GiB (32.5%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
  ID-2: /boot raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 299.9 MiB (30.8%) fs: ext4 dev: /dev/sda7 maj-min: 8:7
  ID-3: /boot/efi raw-size: 600 MiB size: 600 MiB (100.00%)
    used: 30.6 MiB (5.1%) fs: hfsplus dev: /dev/sda6 maj-min: 8:6
  ID-4: /home raw-size: 53.48 GiB size: 53.48 GiB (100.00%)
    used: 17.4 GiB (32.5%) fs: btrfs dev: /dev/sda8 maj-min: 8:8
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 1549
Info:
  Processes: 282 Uptime: 38m wakeups: 0 Memory: 15.5 GiB
  used: 2.15 GiB (13.8%) Init: systemd v: 250 target: graphical (5)
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 Packages:
  note: see --pkg flatpak: 11 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.19

It would be an easy thing turning off bluetooth.service, but once or twice in a week I need my BT headphones, so I don’t think this is really a viable solution.

On the net, I found a bug report on redhat bugzilla that has persisted over 12 years to 2022!

Is that responsible? - Just joking. - Strongly reminds me of false, outdated and misleading Fedora Docs…

But of course, many more people have other Bluetooth issues, such as not working at all, or bad sound, etc.

Any ideas lately? Anyone?!

Blueman isn’t installed. Neither with Fedora XFCE, nor GNOME DEs.
BLUEZ is being Fedora’s choice out of the box.

Would it be safe to install Blueman, given all the latest issues with pipewire, wireplumber and Bluetooth?

Pretty please, advise!

:slight_smile:

What’s providing the bluetooth icon from the screenshot?
You may want to double check that to see if it has an auto power on set.

You could also look at /etc/bluetooth/main.conf for AutoEnable=true and set that to false.
Reference → here

I’m currently running Fedora 36 Gnome off of a minimal install and was able to turn blue tooth on/off from gnome-settings. It does persist through reboots.

Thanks

The bluez package coming with Fedora is providing the BT icon.

Yes! That was indeed auto-tuned to true by Fedora (or Gnome42) with no switch holding across boots in the GUI.

Oftentimes it makes much more sense, to research the Arch-Wiki, instead of Fedora-Docs!

Thank you so much!!

:+1:

I delighted in your “solution” too early, I’m afraid!

Although looking good at first, after a reboot the issue persists despite above new setting of AutoEnable=false in /etc/bluetooth/main.conf (which still remains unchanged after reboot).

:frowning_face:

It seems, Gnome has been having the same history with the issue as Fedora for more than a decade now (see above). I find that outright ridiculous. But then there are people using BT keyboards and/or mouses, so perhaps they’ve been given preference over BT headphones and speakers, out of laziness in implementing a switch to hold across boots (on or off as per user’s choice)…

Anyone here who knows, how to deal with this issue without disabling or masking bluetooth.service?

It would greatly be appreciated!

Strangely enough that works for me on gnome 42, without any modifications.

can you check:
sudo dnf list installed | grep -i blue

what happens if you manually power it on/off manually:
bluetoothctl power off
bluetoothctl power on

thanks

NetworkManager-bluetooth.x86_64                      1:1.38.0-2.fc36                     @updates               
blueberry.noarch                                     1.4.7-3.fc36                        @fedora                
bluez.x86_64                                         5.64-1.fc36                         @anaconda              
bluez-cups.x86_64                                    5.64-1.fc36                         @anaconda              
bluez-libs.x86_64                                    5.64-1.fc36                         @anaconda              
bluez-obexd.x86_64                                   5.64-1.fc36                         @fedora                
bluez-tools.x86_64                                   0.2.0-0.18.git20170912.7cb788c.fc36 @fedora                
gnome-bluetooth.x86_64                               1:42.1-1.fc36                       @updates               
gnome-bluetooth-libs.x86_64                          1:42.1-1.fc36                       @updates               
gnome-bluetooth3.34.x86_64                           3.34.5-1.fc36                       @fedora                
gnome-bluetooth3.34-libs.x86_64                      3.34.5-1.fc36                       @fedora

Changing power off. Succeeded.

Will try a re-boot…

Didn’t change the issue… BT still ON after reboot.

:disappointed_relieved:

Thanks for your patience, @grumpey !

This time, after reboot and switching BT OFF via the panel icon:

$ bluetoothctl power off
Failed to set power off: org.bluez.Error.Busy
$ bluetoothctl power on
Failed to set power on: org.bluez.Error.Failed

After switching BT back ON via panel icon:

$ bluetoothctl power off
Changing power off succeeded

The panel icon controlled BT stays ON. - So, no apparent effect of bluetoothctl at all…

sudo dnf list installed | grep -i blue

NetworkManager-bluetooth.x86_64                      1:1.38.0-2.fc36                     @updates               
blueberry.noarch                                     1.4.7-3.fc36                        @fedora                
bluez.x86_64                                         5.64-1.fc36                         @anaconda              
bluez-cups.x86_64                                    5.64-1.fc36                         @anaconda              
bluez-libs.x86_64                                    5.64-1.fc36                         @anaconda              
bluez-obexd.x86_64                                   5.64-1.fc36                         @fedora                
bluez-tools.x86_64                                   0.2.0-0.18.git20170912.7cb788c.fc36 @fedora                
gnome-bluetooth.x86_64                               1:42.1-1.fc36                       @updates               
gnome-bluetooth-libs.x86_64                          1:42.1-1.fc36                       @updates               
gnome-bluetooth3.34.x86_64                           3.34.5-1.fc36                       @fedora                
gnome-bluetooth3.34-libs.x86_64                      3.34.5-1.fc36                       @fedora

@grumpey :
Do you have the same BT setup? If not, what does yours look like?

No I do not have blueberry or NetworkManager-bluetooth installed

bluez.x86_64                                5.64-1.fc36                       @updates-testing               
bluez-libs.x86_64                           5.64-1.fc36                       @updates-testing               
gnome-bluetooth.x86_64                      1:42.1-1.fc36                     @updates-testing               
gnome-bluetooth-libs.x86_64                 1:42.1-1.fc36                     @updates-testing

So I wasn’t able to reproduce unless I set it to off and immediately restarted, if I waited a bit (more than 5-10 seconds) before restarting I don’t see it.

Finally, SUCCESS!!!

Here’s what I did:

sudo dnf remove NetworkManager-bluetooth
sudo dnf remove blueberry.noarch
sudo dnf list installed | grep -i blue
sudo dnf remove bluez-cups
sudo dnf list installed | grep -i blue
sudo reboot
sudo dnf list installed | grep -i blue
bluetoothctl power on   #success!
sudo dnf install blueman
sudo reboot

Managed to make my BT setup to look the same as yours, then installed blueman, as without it, there was no graphical way to turn BT on / off…

Thank you again @grumpey Joe!

Now it is finally(!) working as it should have been from the beginning, imo, and according to reference.
I.e., Bluetooth setting turned on or off, according to the user’s choice, and holding across a reboot (hibernate or suspend).

:relieved:

1 Like