Bluetooth don't turn on

Bluetooth does not turn on in the settings. The switch appears to have turned on but does not start searching for bluetooth devices and in the shell menu it appears that bluetooth is off but when I open the options there is the option to turn off bluetooth as if it were on, when I select this option the bluetooth disappears from the shell menu.
When the switch is turned of in the settings:
rfkill list

0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Then i did sudo rfkill unblock bluetooth

0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

After this the bluetooth appears on shell menu but still don’t turn on and it appears that bluetooth is off but when I open the options there is the option to turn off bluetooth as if it were on. When a select to turn off bluetooth it dissapears again from shell menu and “rfkill list” gives me:

0: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

Then i tried to do “sudo rfkill unblock bluetooth” and after this i tried “sudo service bluetooth.service start” and the bluetooth appears turned on in the shell menu and in the settings and 100% working. But if i turn off bluetooth from shell or settings i have the same trouble, the bluetooth dissapear from shell menu and don’t turn on. So the only way to turn off the bluetooth without this trouble is doing “sudo service bluetooth.service stop” and if i want turn on do “sudo service bluetooth.service start” again. A want to fix this to turn on and off from the shell or settings and not from terminal. Below is a link to a video showing the problem better.

2 Likes

Hi @ryan.severo1107 , welcome to the forum! Please take a minute to go through the introductory posts in the #start-here category if you’ve not had a chance to do so yet.

Can you please check your journal logs to see what they say when you see this issue, for example when you follow the steps shown in your video? Please paste your logs here for folks to see too.

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

1 Like

Hi everyone,

The same problem was reported in this post. I replied there as well providing some details.

I think many people have this exact same problem. I couldn’t find a solution anywhere and there is no similar bug reported in https://bugzilla.redhat.com/.

I would like to add to my previous reply that as far as I understand (sorry if I am wrong) Bluetooth is supposed to be soft-blocked by rfkill once you turn it off. The problem is it doesn’t turn on at all. As a quick workaround, you could turn it on from settings and then do sudo systemctl restart bluetooth.service from the terminal. That only helps until you turn it off again.

2 Likes

Ty for the help, journalclt show me this when a try to turn on

mai 06 10:21:34 fedora systemd[1]: Starting Load/Save RF Kill Switch Status…
mai 06 10:21:34 fedora systemd[1]: Started Load/Save RF Kill Switch Status.
mai 06 10:21:34 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=‘unit=systemd-rfkill comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
mai 06 10:21:39 fedora systemd[1]: systemd-rfkill.service: Deactivated successfully.

and when i turn off it gives me this

mai 06 10:27:27 fedora systemd[1]: Starting Load/Save RF Kill Switch Status…
mai 06 10:27:27 fedora systemd[1]: Started Load/Save RF Kill Switch Status.
mai 06 10:27:27 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=‘unit=systemd-rfkill comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’
mai 06 10:27:32 fedora systemd[1]: systemd-rfkill.service: Deactivated successfully.
mai 06 10:27:32 fedora audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg=‘unit=systemd-rfkill comm=“systemd” exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success’

@ankursinha there is the logs, ty!
@stiky am doing this till i get the solution for this, ty :slight_smile:

@ryan.severo1107, @ankursinha it says here it is going to be fixed soon.

Fingers crossed.

2 Likes