Bluetooth issue

I have been using garuda linux for quite some time now and then switched to fedora 35 gnome. I am having bluetooth issues , like when i connect my bluetooth earphone it works for some time and then it starts jarring i have not faced this issue ever before and i face it only in fedora. I really like the workspace layout and stuff of fedora 35 (gnome 41.2) but this is a big issue for me since i only have a wireless earphone and my laptop speakers dont work. I will regret it so much if i have to switch back just because of this issue

Hi, maybe you could start with run rfkill list and hwinfo --bluetooth then post the results here (if you never install hwinfo, you could install it first).

My appologize, above should be posted on different user post.

Update:

For jarring sound, maybe you want to try to open Gnome Settings β†’ Sound. Then bellow the option of Output Device, there should be a Configuration drop down menu. You can choose other configuration available there. Make sure to close any music player during selecting the configuration to make sure the configuration can be done smoothly.

The other things, avoid to maximize the volume slider available there too to avoid clipping.

hey sorry for the delayed reply. Its not just jarring. Its like if i pause in between then the connection is kind of lost and i have to reconnect it by putting my earphones back into the case and then reconnecting i never face this issue in android and other linux distros so its like a fedora only issue is there a fix to it

it also shows that wireplumber quits unexpectedly

i think its fixed. I had updated my os and then after a restart it did not occur anymore. Could have been the restart also. I havent done one for close to a week

1 Like

Nope its not fixed its just not often but still sometimes if a ipause something playing and then play it the jarring starts

Would you like to try to install pavucontrol then open the app. On the far right there a β€œConfiguration” tab. From there you would have Profile list as Gnome Settings. Select any profile that works, usually for Bluetooth I uses A2DP Sink with SBC codec as bellow:

Why pavucontrol instead of Gnome Settings? Because sometime (at least for me), Gnome Settings can’t remember the profile I set before.

If above not solve your problem, would you like to follow bellow steps:

From terminal run wpctl status. Find something as bellow from the terminal:

Audio
 β”œβ”€ Devices:
 β”‚      40. Built-in Audio                      [alsa]
 β”‚      41. High Definition Audio Controller    [alsa]
 β”‚      60. EDIFIER W600BT                      [bluez5]
 β”‚  
 β”œβ”€ Sinks:
 β”‚      44. Built-in Audio Analog Stereo        [vol: 0.39]
 β”‚      46. High Definition Audio Controller Digital Stereo (HDMI 2) [vol: 0.74]
 β”‚  *   74. EDIFIER W600BT                      [vol: 0.25]

As you can see above, on part Audio β†’ Sinks, there a list of the Bluetooth device that connected to our system. For above example is 74. EDIFIER W600BT [vol: 0.25]. The 74 is the ID number.

After that run wpctl inspect ID. For above example wpctl inspect 74. Then please post the result here. May be we can figure out something from there.