Bluetooth not working on HP Laptop running Fedora 36

Hello,

Problem :
Going to the settings->Bluetooth page yields the ever
so nice “No Bluetooth Found” message despite my
laptop being equipped with Bluetooth.

Setup :
I’ve got an HP15-da1906nz Laptop running Fedora 36.
I’ve got the system root installed on an NVME SSD,
and my home folder is contained in a seperate 2.5"SSD which
is mounted into the system via an entry in fstab.

Context :
I’ve been running Fedora for a year now, Bluetooth has
never worked despite multiple attempts to remedy this.
I’ve tried multiple solutions described on this forum to no avail.

Question :
What can I do to remedy this ?

May the UNIX gurus brain this !

Wow, what a coincidence! My laptop is from the HP 15 da1xxxx series. For me, bluetooth somehow fixed itself after the latest BIOS update.

Which wifi chip do you have? Post the output of lspci -v | grep -i Network
Should be something like:

lspci -v | grep -i Network
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

Hello,

Wow what a miracle !

lspci -v | grep -i Network
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter

I get exactly the same output as you.

Best,

Did you try to update the BIOS? may need windows unfortunately (HP lazy doesn’t support lvfs).

I looked up your specs, almost exactly the same as mine, except mine shipped with freeDOS instead of windows.
A bit off topic, but how much battery runtime you get? On mine with the NVIDIA card disabled and light load, about 6-8h.

Hello,

I’ve never been able to get my NVIDIA card to work either, nor have I tried.
Battery life is about 3-4 hours.

How does updating the BIOS work ? Do you install a windows utility onto
a usb drive, boot on it and do it there ? Is there a website where I can download
this and the potential BIOS update from HP.

Best

You may try this:

You can get your NVIDIA card to work by installing nvidia drivers from RPMfusion.

If you don’t need the card like me, I disable the card using runtime PM since it draws about 2W on idle.

Copy paste this into a terminal:

echo '#!/bin/bash
# Disable Nvidia GPU while not used
echo 'auto' > '/sys/bus/pci/devices/0000:01:00.0/power/control'
# Fix Lid close acting like airplane mode key
setkeycodes e058 142
# Remove annoying dmesg log when pressing brightness up/down
setkeycodes e02b 240' | sudo tee /etc/rc.d/rc.local
chmod +x /etc/rc.d/rc.local
sudo /etc/rc.d/rc.local

If your device has the exact same motherboard, I expect you have the same issues as I have (no brightness up/down, close the lid=airplane mode), so I added my fixes to some issues to the answer.