Bluetooth only sort of works F33

I upgraded to F33 about a month ago and only recently realized that my bluetooth had stopped working (worked fine in F32). I have tried a few different things but made a weird discovery: if I try to turn on the bluetooth from off to on it doesn’t work and I get a org.bluez.error.notready in the terminal. However, if I leave the bluetooth switched on and then reboot my computer, the bluetooth works.

Does anyone know how to make it consistent? I have a laptop and running my bluetooth all the time drains the battery faster.

I was going to post two screenshots, but I can’t because apparently I’m a new user on here even though I’ve been on here since August of last year :roll_eyes:
Here is a screenshot of what the bluetooth settings window looks like before I reboot

1 Like

I wonder, what happens when you follow the logs in the terminal:

sudo journalctl -f

And then try toggling the setting? Are there any relevant messages (errors (red) or warnings (yellow)) popping up?

No errors show up, but the following happens when I toggle the setting

    Apr 20 19:38:47 localhost.localdomain systemd[1]: Starting Load/Save RF Kill Switch Status...
Apr 20 19:38:47 localhost.localdomain systemd[1]: Started Load/Save RF Kill Switch Status.
Apr 20 19:38:47 localhost.localdomain audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Apr 20 19:38:50 localhost.localdomain NetworkManager[1170]: <info>  [1618961930.0542] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
Apr 20 19:38:50 localhost.localdomain NetworkManager[1170]: <info>  [1618961930.0558] policy: set-hostname: current hostname was changed outside NetworkManager: 'localhost.localdomain'
Apr 20 19:38:52 localhost.localdomain systemd[1]: systemd-rfkill.service: Succeeded.
Apr 20 19:38:52 localhost.localdomain audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

The “SERVICE_STOP” shows up before I toggle the Bluetooth switch off.

Hi,

I had this problem on Fedora 33 and now on Fedora 34 as well.

The bluetooth works fine after fresh installation but as soon as I restart my laptop it becomes soft blocked by rfkill:

image

At first it is not even listed as blocked but after I toggle it several times from settings and from the top bar as well it becomes listed as soft blocked.

I have the same output in the console like @ourlastdefeat:

Apr 21 14:04:29 fedora systemd[1]: Starting Load/Save RF Kill Switch Status...
Apr 21 14:04:29 fedora systemd[1]: Started Load/Save RF Kill Switch Status.
Apr 21 14:04:29 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Apr 21 14:04:34 fedora systemd[1]: systemd-rfkill.service: Deactivated successfully.
Apr 21 14:04:34 fedora audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

Thank you.

Does rfkill unblock the device help?

Only if I do the following:

  1. Turn it on from Settings->Bluetooth
  2. rfkill unblock
  3. Suspend the laptop

Once I wake-up the laptop, bluetooth is on but only until I turn it off. Then I have to do the whole procedure again.

1 Like

The issue has been identified and fixed in Rawhide. An update should soon be available for F34 as well. See RHBZ#1944482 for more details.

In the meantime, a sudo systemctl restart bluetooth should get your Bluetooth going again.

1 Like

Thank you so much. Looking forward to the fix.

EDIT: Just linking this other topic for the same bug.

So the update is up, but it hasn’t been pushed to testing yet. Once it’s available, don’t forget to test and add karma.

1 Like

Hi, it is working for me. Thank you so much!

1 Like