Booting into Fedora after install in Windows/MXLinux dual-boot system

Hello there!

I want to try Fedora out on my current laptop, but haven’t had success so far. Well, the live experience was fine, except my system has a Broadcom wifi adapter, and from what little reading i’ve done, it seems that getting Fedora to recognize the wl driver requires a reboot after installing the driver from the nonfree rpmfusion repository, and unfortunately i had built the live usb in the recommended way (Fedora Media Writer), which means no live persistence. Between rebuilding the usb to have persistence, and just biting the bullet and installing on hard drive, i went with the install.

Well, i can offer more details on my system, but basically, it’s an UEFI Windows machine i’ve also installed MX-Linux 18.3 on.

Anyway, after freeing about 50 GiB of space, i installed Fedora, mostly on default settings including partitioning which i left as automatic. After the install finished, i rebooted the laptop, without the live usb, but was greeted with an unchanged GRUB menu containing only the MXLinux and Windows choices.

How do i get to my Fedora install?
(i’m pretty sure it’s there? the automatic partitioning seems to have created two new partitions, an 1gb one that seems to contain boot-related files, and another one with the rest of the free space with home and root, titled fedora_localhost-live)

You used automatic partitioning. That means fedora created a new efi partition.

I suggest a reinstall with custom partitioning where you tell it to use the existing efi partition and mount it at /boot/efi without formatting. You should then use the 1G partition as ext4 mounted at /boot and use the other which appears to be LVM for / and /home. Fedora will create a grub menu that should allow booting to any of the three installed OSes as long as they use the same efi partition. With an extra efi partition that is not the boot partition fedora is not seen by your original config.

Creating the live usb is really very simple using dd, but those built with fedora media writer (even from windows) should function the same. I am not sure what you mean by “no live persistence” as you are in “live” mode only until you actually start the install.

2 Likes

Thank you for the help.

Upon reaching the custom partitioning screen, i figured out that, turns out, the automatic partitioning did use the existing efi partition! After quitting without reinstalling, i set out to try to boot the currently installed Fedora.

I have succeeded at this. The “efibootmgr” command returned a list of things, one of which was Fedora. Strangely, any changes i attempted to the boot order (“efibootmgr -o …”) were lost on a restart, but directly setting the next boot (“efibootmgr -n …”) did the trick.

I don’t really understand anything about booting (for example, the list efibootmgr returns is different from what i can see on the BIOS menu, also the boot order listed by efibootmgr is different if i boot from the live usb), but for now i’m satisfied.

Oh, and to explain what i meant by “persistence”; the official Fedora docs call it “data persistence”, see https://docs.fedoraproject.org/en-US/quick-docs/creating-and-using-a-live-installation-image/

Depending on which UEFI bios you have the devices are often displayed in the order detected and that may or may not match the bios boot order since the bios boot order sets the device but not the partition while the bios boot display shows it in finer grain.

Efibootmgr should set the boot order from efi. -o sets the several devices permanently in the order listed AFAICT, while -n only sets the device for the next boot. To make any changes permanent it has to be run as root or with sudo.

After you have booted into the installed fedora then running

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg 

should properly configure grub so you can select any of the installed OSes for boot from the menu when you first power on.

You did not say which version of fedora you installed. I have one system with F32 and another with F33.