Borgmatic is borked

Trying to install borgmatic fails due to a missing pinned dependency:

Problem: conflicting requests

  • nothing provides python3.7dist(ruamel.yaml) <= 0.15 needed by borgmatic-1.2.0-3.fc30.x86_64

Also, a newer version of borgmatic as been available for some time.

Bug reports have been open for a year:

borgmatic 1.3.15 is released. Simply updating borgmatic would perhaps solve the dependency error blocking installation, since the pinning to an older version was resolved in an issue and recent release:

The package in Fedora’s repos seems abandoned. Someone tried to become the maintainer. Another created a copr.

For now, the simplest method seems to be to just install directly with: sudo pip3 install --user --upgrade borgmatic as per the documentation, notwithstanding standard warnings against using pip/pip3 as root.