Broken steam dependencies, refuses to install

Trying to install steam, after enabling rpm repository etc, sudo dnf install steam returns
Problem: conflicting requests

  • package steam-1.0.0.72-1.fc35.i686 requires libcurl(x86-32), but none of the providers can be installed
  • package steam-1.0.0.74-1.fc35.i686 requires libcurl(x86-32), but none of the providers can be installed
  • package libcurl-7.78.0-3.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-minimal-7.78.0-3.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-7.79.1-1.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-minimal-7.79.1-1.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libnghttp2-1.45.1-1.fc35.i686 is filtered out by modular filtering
    (try to add ‘–skip-broken’ to skip uninstallable packages)

I am very lost on what to do in order to fix these broken packages

Are you trying to install from terminal; e.g., sudo dnf install steam?

If so, did you add the rpmfusion repo with sudo dnf install https://mirrors.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm?

Yes & Yes!

Got it… Have you upgraded the system lately? An error like that can, sometimes, be caused by an out-of-date system. If you’re all up-to-date, have you tried the flatpak version of Steam?

Also, Fedora 35 doesn’t seem to have the 32-bit package, just 64-bit…

No, i am fully up to date. I have tried using the flatpak version which gets me through to a working steam, but that gives me issues with proton-ge not being installed as well as my second hard drive (where all my games are installed) not being recognised by steam when installed this way.

Understood. I’m not sure why the required libcurl version is 32, perhaps someone else might be able to shed light on that.

For the flatpak issues, have you seen this project; it looks like it will fix your proton-ge issue. You can then address the directory limitations by using Flatsealflatpak install flatseal—which will allow you to give Steam access to additional directories, like your external drive.

1 Like

Do you use modules? What is the output of:

sudo dnf module list
2 Likes
Fedora Modular 35 - x86_64
Name               Stream           Profiles                Summary                                                   
avocado            latest           default [d], minimal    Framework with tools and libraries for Automated Testing  
avocado            82lts            default, minimal        Framework with tools and libraries for Automated Testing  
avocado-vt         latest           default                 Avocado Virt Test Plugin                                  
avocado-vt         82lts            default                 Avocado Virt Test Plugin                                  
cri-o              1.19             default                 Kubernetes Container Runtime Interface for OCI-based conta
                                                            iners                                                     
ghc                8.8              default [d], minimal, s Haskell GHC 8.8                                           
                                    mall                                                                              
ghc                8.10             all, default [d], minim Haskell GHC 8.10                                          
                                    al, small                                                                         
ghc                9.0              all, default [d], minim Haskell GHC 9.0                                           
                                    al, small                                                                         
ghc                9.2              all, default, minimal,  Haskell GHC 9.2                                           
                                    small                                                                             
mariadb            10.3             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server [d]                                                                        
mariadb            10.4             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server [d]                                                                        
mariadb            10.5             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server [d]                                                                        
mysql              8.0              client, devel, server [ MySQL Module                                              
                                    d]                                                                                
nextcloud          nextcloud-stable default, testing        A private file sync and share server - Stable branch      
nextcloud          nextcloud-19     default, testing        A private file sync and share server - version 19.0.x     
nextcloud          nextcloud-20     default, testing        A private file sync and share server - version 20.0.x     
nextcloud          nextcloud-21     default, testing        A private file sync and share server - version 21.0.x     
nextcloud          nextcloud-22     default, testing        A private file sync and share server - version 22.0.x     
nginx              mainline         common [d]              nginx webserver                                           
nginx              1.20             common                  nginx webserver                                           
nodejs             12               default [d], developmen Javascript runtime                                        
                                    t, minimal                                                                        
nodejs             14               default, development, m Javascript runtime                                        
                                    inimal                                                                            
nodejs             15               default, development, m Javascript runtime                                        
                                    inimal                                                                            
nodejs             16 [e]           default, development [i Javascript runtime                                        
                                    ], minimal                                                                        
perl               5.30             common, default [d], mi Practical Extraction and Report Language                  
                                    nimal                                                                             
perl               5.32             common [d], minimal     Practical Extraction and Report Language                  
perl-App-cpanminus 1.7044           common [d]              Get, unpack, build and install CPAN modules               
perl-CGI           4.51             common                  Handle Common Gateway Interface requests and responses    
perl-DBD-MySQL     4.050            common [d]              A MySQL interface for Perl                                
perl-DBD-Pg        3.14             common [d]              A PostgreSQL interface for Perl                           
perl-DBD-SQLite    1.66             common [d]              SQLite DBI driver                                         
perl-DBI           1.643            common [d]              A database access API for Perl                            
perl-Date-Manip    6.83             common [d]              Date manipulation routines                                
perl-FCGI          0.79             common [d]              FastCGI Perl bindings                                     
perl-IO-Socket-SSL 2.068            common [d]              Perl library for transparent TLS                          
perl-IO-stringy    2.113            common                  I/O on in-core objects like strings and arrays for Perl   
perl-XML-Parser    2.46             common [d]              Perl module for parsing XML documents                     
perl-YAML          1.30             common [d]              Perl parser for YAML                                      
perl-libwww-perl   6.48             common [d]              A Perl interface to the World-Wide Web                    
postgresql         11               client, server [d]      PostgreSQL module                                         
postgresql         12               client, server          PostgreSQL module                                         
postgresql         13               client, server          PostgreSQL module                                         
ruby               2.7              default [d]             An interpreter of object-oriented scripting language      
ruby               3.0              default [d]             An interpreter of object-oriented scripting language      
swig               4.0              complete, default [d]   Connects C/C++/Objective C to some high-level programming 
                                                            languages                                                 
varnish            6.0              default                 Varnish HTTP cache                                        

Fedora Modular 35 - x86_64 - Updates
Name               Stream           Profiles                Summary                                                   
avocado            latest           default [d], minimal    Framework with tools and libraries for Automated Testing  
avocado            82lts            default, minimal        Framework with tools and libraries for Automated Testing  
avocado-vt         latest           default                 Avocado Virt Test Plugin                                  
avocado-vt         82lts            default                 Avocado Virt Test Plugin                                  
cri-o              1.19             default                 Kubernetes Container Runtime Interface for OCI-based conta
                                                            iners                                                     
cri-o              1.20             default                 Kubernetes Container Runtime Interface for OCI-based conta
                                                            iners                                                     
cri-o              1.21             default                 Kubernetes Container Runtime Interface for OCI-based conta
                                                            iners                                                     
cri-o              1.22             default                 Kubernetes Container Runtime Interface for OCI-based conta
                                                            iners                                                     
dwm                latest           default [d], user       Dynamic window manager for X                              
dwm                6.0              default [d], user       Dynamic window manager for X                              
dwm                6.1              default [d], user       Dynamic window manager for X                              
dwm                6.2              default [d], user       Dynamic window manager for X                              
ghc                8.8              default [d], minimal, s Haskell GHC 8.8                                           
                                    mall                                                                              
ghc                8.10             all, default [d], minim Haskell GHC 8.10                                          
                                    al, small                                                                         
ghc                9.0              all, default [d], minim Haskell GHC 9.0                                           
                                    al, small                                                                         
ghc                9.2              all, default, minimal,  Haskell GHC 9.2                                           
                                    small                                                                             
mariadb            10.3             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server [d]                                                                        
mariadb            10.4             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server [d]                                                                        
mariadb            10.5             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server [d]                                                                        
mariadb            10.6             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server                                                                            
mariadb            10.7             client, devel, galera,  MariaDB: a very fast and robust SQL database server       
                                    server                                                                            
mysql              8.0              client, devel, server [ MySQL Module                                              
                                    d]                                                                                
nextcloud          nextcloud-stable default, testing        A private file sync and share server - Stable branch      
nextcloud          nextcloud-19     default, testing        A private file sync and share server - version 19.0.x     
nextcloud          nextcloud-20     default, testing        A private file sync and share server - version 20.0.x     
nextcloud          nextcloud-21     default, testing        A private file sync and share server - version 21.0.x     
nextcloud          nextcloud-22     default, testing        A private file sync and share server - version 22.0.x     
nginx              mainline         common [d]              nginx webserver                                           
nginx              1.20             common                  nginx webserver                                           
nodejs             12               default [d], developmen Javascript runtime                                        
                                    t, minimal                                                                        
nodejs             14               default, development, m Javascript runtime                                        
                                    inimal                                                                            
nodejs             15               default, development, m Javascript runtime                                        
                                    inimal                                                                            
nodejs             16 [e]           default, development [i Javascript runtime                                        
                                    ], minimal                                                                        
openmpi            4.0              buildroot, default [d]  Open Message Passing Interface                            
perl               5.30             common, default [d], mi Practical Extraction and Report Language                  
                                    nimal                                                                             
perl               5.32             common [d], minimal     Practical Extraction and Report Language                  
perl-App-cpanminus 1.7044           common [d]              Get, unpack, build and install CPAN modules               
perl-CGI           4.51             common                  Handle Common Gateway Interface requests and responses    
perl-DBD-MySQL     4.050            common [d]              A MySQL interface for Perl                                
perl-DBD-Pg        3.14             common [d]              A PostgreSQL interface for Perl                           
perl-DBD-SQLite    1.66             common [d]              SQLite DBI driver                                         
perl-DBI           1.643            common [d]              A database access API for Perl                            
perl-Date-Manip    6.83             common [d]              Date manipulation routines                                
perl-FCGI          0.79             common [d]              FastCGI Perl bindings                                     
perl-IO-Socket-SSL 2.068            common [d]              Perl library for transparent TLS                          
perl-IO-stringy    2.113            common                  I/O on in-core objects like strings and arrays for Perl   
perl-XML-Parser    2.46             common [d]              Perl module for parsing XML documents                     
perl-YAML          1.30             common [d]              Perl parser for YAML                                      
perl-libwww-perl   6.48             common [d]              A Perl interface to the World-Wide Web                    
postgresql         10               client, server [d]      PostgreSQL module                                         
postgresql         11               client, server [d]      PostgreSQL module                                         
postgresql         12               client, server          PostgreSQL module                                         
postgresql         13               client, server          PostgreSQL module                                         
postgresql         14               client, server          PostgreSQL module                                         
ruby               2.7              default [d]             An interpreter of object-oriented scripting language      
ruby               3.0              default [d]             An interpreter of object-oriented scripting language      
sway               rolling          default [d], full       i3-compatible window manager for Wayland                  
swig               4.0              complete, default [d]   Connects C/C++/Objective C to some high-level programming 
                                                            languages                                                 
varnish            6.0              default                 Varnish HTTP cache                                        

Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled

1 Like

Use the Flatpak version, you will have less headache.

… I was able to install this with flatpak from flat hub.

flatpak install com.valvesoftware.Steam.CompatibilityTool.Proton-GE

It’s not an official build

Just circling back, @zlatko49; were you able to get things up and running?

Just stepping in to this.
Have you tried sudo dnf install steam --allowerasing ?
That may fix the issue.
I have installed steam on both Fedora 34 & 35 and both work well when installed from the rpmfusion repo.
Looking at what you have posted I think this is likely the clue and fixing that would solve the install issue.
package libnghttp2-1.45.1-1.fc35.i686 is filtered out by modular filtering (try to add ‘–skip-broken’ to skip uninstallable packages)

Have you looked here? It may have the solution for you.

1 Like

Hi, i issued sudo dnf install steam --allowerasing

Error:
Problem: conflicting requests

  • package steam-1.0.0.72-1.fc35.i686 requires libcurl(x86-32), but none of the providers can be installed
  • package steam-1.0.0.74-1.fc35.i686 requires libcurl(x86-32), but none of the providers can be installed
  • package libcurl-7.78.0-3.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-minimal-7.78.0-3.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-7.79.1-1.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-minimal-7.79.1-1.fc35.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libnghttp2-1.45.1-1.fc35.i686 is filtered out by modular filtering
    (try to add ‘–skip-broken’ to skip uninstallable packages)

in regards to the second part about libnghttp2, i have installed and reinstalled all the packages that come up but it doesn’t seem to change the output of trying to install steam, id love to use the flatpak but my secondary hard drive is still not coming up after trying flatseal.

I can get steam working through flatpak and a slightly older version of proton ge which im not too worried about but i can’t exactly play my games because flatseal isn’t fixing my previous issue with flatpak steam where i can’t get it to access my second hdd.

edit

sudo dnf install libnghttp2.so.14
Last metadata expiration check: 0:01:51 ago on Wed 29 Dec 2021 10:43:18.
All matches were filtered out by modular filtering for argument: libnghttp2.so.14
Error: Unable to find a match: libnghttp2.so.14

Please try to install:

sudo dnf install libcurl-7.79.1-1.fc35.i686 

It will include the libnghttp2 package as dependencies.

If you already installed both packages, try with:

sudo dnf reinstall libcurl-7.79.1-1.fc35.i686 

Update:

Turn out when I install both libcurl and libcurl-minimal it make conflict (immediately I edit my suggestion above). I check on my system with installed steam it only have libcurl.i686 and libcurl.x86_64 with version above for .i686.

It might give us some more info to use if you were to post the output of sudo dnf repolist . The link I posted above showed that there was a conflicting repo enabled that triggered the modular filtering error.

@computersavvy :thinking: so it’s about modular packages. I’m not familiar with those kind of things. May be you could also check here and may be it would help @zlatko49.

Can you share how you entered the path to your external hd in Flatseal?

1 Like

The conflict appears to be with the nodejs module and steam

you could try:
sudo dnf module disable nodejs
sudo dnf install steam
sudo dnf module install nodejs:16/development

you’d want to check your environment afterwards to make sure everything is working.

If you’re interested in running the flatpak, I’d check what @bryanmoore said regarding the path. You may need to use /run/media/ or other file path in flat seal depending on where you’re mounting it.

Depending on what you are doing, you may also consider running nodejs in a toolbox or other container to keep it separate.

edit:
https://bugzilla.redhat.com/show_bug.cgi?id=1778327

If you install with the module disabled, it will complain during updates that it can’t install the best version. (same problem in reverse)

1 Like