Broken update and transaction error

Hi all,
I can’t update, after I run dnf update I get a transaction error because I have package conflicts.
How can I solve? Thanks

Test di transazione in corso
I pacchetti scaricati sono stati salvati nella cache fino alla prossima transazione completata con successo.
È possibile rimuovere i pacchetti in cache eseguendo 'dnf clean packages'.
Errore: Errore nel controllo di transazione:
  il file /usr/share/doc/libgpg-error/ChangeLog dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/doc/libgpg-error/NEWS dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/doc/libgpg-error/README dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/libgpg-error/errorref.txt dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/cs/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/da/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/de/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/eo/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/es/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/fr/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/hu/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/it/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/ja/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/nl/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/pl/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/pt/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/ro/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/ru/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/sr/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/sv/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/uk/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/vi/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/zh_CN/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/locale/zh_TW/LC_MESSAGES/libgpg-error.mo dell'installazione di libgpg-error-1.33-1.fc29.i686 entra in conflitto con il file del pacchetto libgpg-error-1.31-2.fc29.x86_64
  il file /usr/share/doc/nettle/NEWS dell'installazione di nettle-3.4.1rc1-1.fc29.i686 entra in conflitto con il file del pacchetto nettle-3.4-5.fc29.x86_64
  il file /usr/share/libdrm/amdgpu.ids dell'installazione di libdrm-2.4.97-1.fc29.i686 entra in conflitto con il file del pacchetto libdrm-2.4.95-1.fc29.x86_64
  il file /usr/share/doc/libjpeg-turbo/ChangeLog.md dell'installazione di libjpeg-turbo-2.0.2-1.fc29.i686 entra in conflitto con il file del pacchetto libjpeg-turbo-2.0.0-1.fc29.x86_64
  il file /usr/share/licenses/libjpeg-turbo/LICENSE.md dell'installazione di libjpeg-turbo-2.0.2-1.fc29.i686 entra in conflitto con il file del pacchetto libjpeg-turbo-2.0.0-1.fc29.x86_64
1 Like

Try this way:

sudo dnf clean all
sudo dnf distro-sync
sudo dnf remove --duplicates