Bug: system selects invalid user ID when creating new users

When creating a new user (in MATE: Administration -> Users and Groups), the new user was unable to log in properly (blank black screen). It turns out this is due to the system assigning an invalid user ID by default.

Deleting the account and recreating it by manually selecting a valid user ID resolves the problem.

The problem and solution are described here. Fortunately Fedora AskBot content is still available. :wink:

Specifically, from user “villykruse”:

you created the user with a user id of 65535 which is a magic value for invalid user id. Seen as a 16-bin integer this value is the same as -1.

It is a bit unfortunate that system-config-users would allow you to specify that number, or any other number which have been used already. As a bit of advice, let system-config-users chose the next available number, for example 1001.

There is a bug in system-config-users in that the user nobody with user id 65534 is regarded wrongly as a regular user, and therefore it takes this as the highest user id used so far. The next one will then be 65535 which is considered invalid.

For systems that has been upgraded through several fedora releases, the user 65534 is named nfsnobody , and that user name is ignored when searching for the highest user id used.

The old entries in /etc/passwd looks like that

nobody:x:99:99:Nobody:/:/sbin/nologin
nfsnobody:x:65534:65534:Anonymous NFS User:/var/lib/nfs:/sbin/nologin

And with these lines system-config-users works properly.

How is such a serious bug still not fixed? :stuck_out_tongue: