Can window size for newly launched apps on Gnome be configured?

Does Gnome have any knobs anywhere to control window size when launching apps? I find it a bit chaotic - sometimes maximised, sometimes not, and seemingly bearing no relation to the window size when I last used & closed the same app. This even seems to be true for apps with their own window size config (eg kitty which has related settings in its config).

I’m on Fedora 36, with a pretty vanilla installation (Gnome 42, wayland).

1 Like

It’s supposed to remember the size of the window, but I believe there is a bug that keeps increasing the size of windows. I can’t find the original link, but this might be the related issue:

Based only on a quick scan of that thread (I admit to not reading it all!) that’s a different issue - it affects X11, not Wayland, and it has a pattern (windows monotonically increase in size).

There’s no particular pattern to window size on my system. Sometimes windows will open maximised, sometimes not. This happens with all apps, even those you’d expect to be most well-behaved (eg. Gnome settings).

Early days, but I think I’ve found the solution.

There’s a dconf setting org.gnome.mutter auto-maximize which is supposed to automatically maximise a new window only if it’s near the monitor size. It’s true by default, and on my system it’s clearly buggy and operates on many new smaller windows. Thinking about it, it’s quite a complex task with all the possible variations of multiple monitors, resolutions and scaling.

Anyway, setting this to false seems to sort the issue out in my case.

[aside: bug report here: Auto-maximize is over eager (#2275) · Issues · GNOME / mutter · GitLab]

1 Like

I am not familiar with dconf (or gsettings) and even after reading the related man pages have been unable to change the value of org.gnome.mutter auto-maximize

Could you please provide any pointers needed as to how to change that value.
gsettings set org.gnome.mutter auto-maximize "false" does not work even though the man page seems to indicate that is the proper way to do so. gsettings get org.gnome.mutter auto-maximize returns ‘true’ and gsettings list-recursively org.gnome.mutter lists all the keys and values for org.gnome.mutter.

This is the error received when I try setting that value, and I am actually logged in as root.

[root@eagle Can-Am]# gsettings set org.gnome.mutter auto-maximize 'false'

(process:32933): dconf-WARNING **: 22:15:17.380: failed to commit changes to dconf: Error sending credentials: Error sending message: Broken pipe

Not sure - you’re invoking gsettings correctly. You mention being logged in as root - if you’re logged into gnome as a regular user, and you’re root in the terminal, I’d imagine that would cause problems. If so, just do everything as your regular user.

Otherwise give the dconf GUI a try - I like the terminal as much as most of us, but for this purpose I find the GUI much more legible, with more useful context. The package is dconf-editor IIRC.

Thanks.
I assumed a user needed root privileges to change dconf settings. Guess I was wrong.

Appreciate the heads up on that.
:face_with_open_eyes_and_hand_over_mouth: