Cannot install Anydesk

Hi there,

Just wondering if anyone has successfully installed the Fedora repo for anydesk.

When adding the repo from Anydesk recommended command I get this error:

[root@fedora isaiah]# dnf install anydesk
Last metadata expiration check: 0:01:44 ago on Thu 01 Sep 2022 20:27:08.
Error: 
 Problem: conflicting requests
  - nothing provides libgtkglext-x11-1_0-0 needed by anydesk-6.2.0-1.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

I added the repo with the command as specified from anydesk:

cat > /etc/yum.repos.d/AnyDesk-Fedora.repo << "EOF" 
[anydesk]
name=AnyDesk Fedora - stable
baseurl=http://rpm.anydesk.com/fedora/$basearch/
gpgcheck=1
repo_gpgcheck=1
gpgkey=https://keys.anydesk.com/repos/RPM-GPG-KEY
EOF
1 Like

Generally, the repo seems to work fine. But I would add the line metadata_expire=6h because this repo seems to be also intended to provide potential (security) updates for the package you want to install. Especially security updates should be installed asap. Formally, type=rpm might be added as well to make everything explicit but this is unlikely to cause an issue (dnf should enforce this indirectly anyway).

The reason for the error is not the repo but the package: the package you want to install needs another package: libgtkglext-x11-1_0-0 → this is not contained in any repo.

However, you maybe try a refresh (the data you provided doesn’t show the state of the database) before we elaborate more sophisticated troubleshooting: dnf install anydesk --refresh → please provide the whole output of this command, just to see what repos are currently involved.

Be aware that this repository is maintained by anydesk (not the Fedora community!) and therefore, this repository has not undergone the testing and quality assurance of the Fedora community!

1 Like

I’ve been seeing this for a while, and I’ve also reported it to Anydesk but have not seen any action about it. The last version that works (and is still working for me) is:

$ rpm -q anydesk
anydesk-6.1.1-1.x86_64

Their official stance seems to be that “Fedora is not supported”:

I’ve read that the Flatpak works, so maybe that’s worth checking out:

Although this is also currently at version 6.1.1

1 Like

Thanks for clarification, I knew there was some kind of dependency but wasn’t sure if it was the repo having trouble adding it or the dependency not installing.

I am running the flatpak version with no trouble and it talks Fedora to mac and fedora to windows very very well and vica versa,

The anydesk guys have not updated the flatpak version and its outdated and that’s why I am trying to install the Fedora version.

I might just wait,

thanks for the confirmation.

The error is at the bottom precisely as you described, shouldn’t we be able to try the Redhat version or centos version as they run the yum package also?

[isaiah@fedora ~]$ sudo dnf install anydesk --refresh
[sudo] password for isaiah: 
AnyDesk Fedora - stable                         245  B/s | 488  B     00:01    
created by dnf config-manager from https://brav 827  B/s | 3.3 kB     00:04    
created by dnf config-manager from https://brav  26 kB/s | 8.7 kB     00:00    
Fedora 36 - x86_64                              1.2 kB/s | 3.5 kB     00:02    
Fedora 36 openh264 (From Cisco) - x86_64        1.3 kB/s | 989  B     00:00    
Fedora Modular 36 - x86_64                      6.6 kB/s | 3.4 kB     00:00    
determining the fastest mirror (9 hosts).. done.---  B/s |   0  B     --:-- ETA
Fedora 36 - x86_64 - Updates                     12 kB/s |  30 kB     00:02    
done.a 36 - x86_64 - 45% [=========           ]  42 kB/s |  14 kB     00:00 ETA
Fedora 36 - x86_64 - Updates                    447 kB/s | 2.9 MB     00:06    
Fedora Modular 36 - x86_64 - Updates            5.5 kB/s | 3.1 kB     00:00    
google-chrome                                   3.8 kB/s | 1.3 kB     00:00    
google-chrome                                   5.6 kB/s | 3.5 kB     00:00    
onlyoffice repo                                 7.5 kB/s | 2.9 kB     00:00    
ROCm 5.0.2 repository                           639  B/s | 2.9 kB     00:04    
created by dnf config-manager from https://rpm.librewolf.net                                                               1.1 kB/s | 3.0 kB     00:02    
RPM Fusion for Fedora 36 - Free                                                                                            4.7 kB/s |  12 kB     00:02    
RPM Fusion for Fedora 36 - Free - Updates                                                                                  9.6 kB/s |  11 kB     00:01    
RPM Fusion for Fedora 36 - Nonfree                                                                                          10 kB/s |  13 kB     00:01    
RPM Fusion for Fedora 36 - Nonfree - Updates                                                                                11 kB/s |  11 kB     00:01    
skype (stable)                                                                                                             854  B/s | 2.9 kB     00:03    
skype (stable)                                                                                                             6.2 kB/s | 5.0 kB     00:00    
TeamViewer - x86_64                                                                                                        308  B/s | 867  B     00:02    
Error: 
 Problem: conflicting requests
  - nothing provides libgtkglext-x11-1_0-0 needed by anydesk-6.2.0-1.x86_64
(try to add '--skip-broken' to skip uninstallable packages)

It isn’t maintained by the AnyDesk devs, though:

“NOTE: This wrapper is not verified by, affiliated with, or supported by AnyDesk.”

So, we should not assume that Flatpaks are maintained by developers. Absolutely anyone can build and submit a Flatpak to Flathub.

2 Likes

Ah I see thanks for pointing that out, i thought there were “official” and “unofficial” flatpaks like unofficial fedora packages like the copr repo.