Cannot install both qt5-qtbase

While running my daily updates today, I’ve got the following errors:

 Problem 1: cannot install both qt5-qtbase-5.12.5-1.fc30.x86_64 and qt5-qtbase-5.12.4-4.fc30.x86_64
  - package calibre-3.36.0-8.fc30.x86_64 requires libQt5Core.so.5(Qt_5.12.4_PRIVATE_API)(64bit), but none of the providers can be installed
  - package calibre-3.36.0-8.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.12.4, but none of the providers can be installed
  - cannot install the best update candidate for package qt5-qtbase-5.12.4-4.fc30.x86_64
  - cannot install the best update candidate for package calibre-3.36.0-8.fc30.x86_64
 Problem 2: package telegram-desktop-1.8.9-1.fc30.x86_64 requires libQt5Gui.so.5(Qt_5.12.4_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt5-qtbase-gui-5.12.5-1.fc30.x86_64 and qt5-qtbase-gui-5.12.4-4.fc30.x86_64
  - cannot install the best update candidate for package telegram-desktop-1.8.9-1.fc30.x86_64
  - cannot install the best update candidate for package qt5-qtbase-gui-5.12.4-4.fc30.x86_64
 Problem 3: problem with installed package telegram-desktop-1.8.9-1.fc30.x86_64
  - package telegram-desktop-1.8.9-1.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.12.4, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.12.5-1.fc30.x86_64 and qt5-qtbase-5.12.4-4.fc30.x86_64
  - package python2-qt5-base-5.12.3-6.fc30.x86_64 requires libQt5Core.so.5(Qt_5.12.5_PRIVATE_API)(64bit), but none of the providers can be installed
  - package python2-qt5-base-5.12.3-6.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.12.5, but none of the providers can be installed
  - cannot install the best update candidate for package python2-qt5-base-5.12.2-5.fc30.x86_64
 Problem 4: problem with installed package calibre-3.36.0-8.fc30.x86_64
  - package calibre-3.36.0-8.fc30.x86_64 requires libQt5Core.so.5(Qt_5.12.4_PRIVATE_API)(64bit), but none of the providers can be installed
  - package calibre-3.36.0-8.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.12.4, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.12.5-1.fc30.x86_64 and qt5-qtbase-5.12.4-4.fc30.x86_64
  - package qgnomeplatform-0.5-11.fc30.x86_64 requires qt5-qtbase(x86-64) = 5.12.5, but none of the providers can be installed
  - cannot install the best update candidate for package qgnomeplatform-0.5-10.fc30.x86_64

Skipping packages with conflicts:
(add '--best --allowerasing' to command line to force their upgrade):
 qt5-qtbase                                    x86_64                              5.12.5-1.fc30                                updates                              3.5 M
 qt5-qtbase-gui                                x86_64                              5.12.5-1.fc30                                updates                              6.0 M

If I run the command with --best --allowerasing, dnf sugests both calibre and telegram-desktop to be uninstalled.

I hope that it’s just some dependency issue, and at a later date, the dependency will be solved and my dnf upgrade will run without issues.

1 Like

It looks like there was an issue in the qt5 update that was pushed to the stable repository.

3 Likes

It look like the same thing.

So nothing else to do but wait for them to fix the dependencies conflict.

2 Likes

@biosharkdev Look at Calibre removed

1 Like

Yes, I saw that. But it’s still not released yet to the normal update channel. Hopefully somebody is looking into telegram-desktop as well.

At any rate, the 2 apps are working fine so far, no need to panic. They will sort the dependency out eventually.

1 Like

All good now after today’s update!

2 Likes

And I have got this as well after updating from 5.2.18-200 to 5.3.5-200 yesterday.

Help me please :disappointed:

@afdrnk this is unrelated to the topic of this thread.

Look here Fedora 30 vmlinuz crashing

Btw I sporadically have the same issue. This message appears after the boot (and login to gnome). But as far as I understand it is harmless and the system works without any issue.

1 Like