Cannot install the best update candidate for package sddm-breeze-5.20.4-1.fc33.noarch

Hello,

I am unable to install a bunch of packages.

Operating System: Fedora 33
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.2
Kernel Version: 5.9.16-200.fc33.x86_64
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6820HQ CPU @ 2.70GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 530
$ sudo dnf -y --refresh update --best --allowerasing
Fedora 33 openh264 (From Cisco) - x86_64                                                                                                                                          1.9 kB/s | 989  B     00:00    
Fedora Modular 33 - x86_64                                                                                                                                                         22 kB/s | 6.7 kB     00:00    
Fedora Modular 33 - x86_64 - Updates                                                                                                                                               22 kB/s | 5.9 kB     00:00    
Fedora 33 - x86_64 - Updates                                                                                                                                                       25 kB/s | 7.1 kB     00:00    
Fedora 33 - x86_64                                                                                                                                                                 22 kB/s | 6.8 kB     00:00    
RPM Fusion for Fedora 33 - Free - Updates                                                                                                                                         1.9 kB/s | 2.1 kB     00:01    
RPM Fusion for Fedora 33 - Free                                                                                                                                                   2.2 kB/s | 2.4 kB     00:01    
RPM Fusion for Fedora 33 - Nonfree - Updates                                                                                                                                      8.0 kB/s |  11 kB     00:01    
RPM Fusion for Fedora 33 - Nonfree                                                                                                                                                8.7 kB/s |  11 kB     00:01    
Error: 
 Problem 1: cannot install the best update candidate for package sddm-breeze-5.20.4-1.fc33.noarch
  - problem with installed package sddm-breeze-5.20.4-1.fc33.noarch
  - nothing provides kf5-plasma >= 5.78.0 needed by sddm-breeze-5.20.5-1.fc33.noarch
 Problem 2: cannot install the best update candidate for package plasma-workspace-5.20.4-1.fc33.x86_64
  - problem with installed package plasma-workspace-5.20.4-1.fc33.x86_64
  - nothing provides kf5-plasma(x86-64) >= 5.78.0 needed by plasma-workspace-5.20.5-1.fc33.x86_64
 Problem 3: cannot install the best update candidate for package plasma-desktop-5.20.4-2.fc33.x86_64
  - problem with installed package plasma-desktop-5.20.4-2.fc33.x86_64
  - nothing provides kf5-plasma(x86-64) >= 5.78.0 needed by plasma-desktop-5.20.5-1.fc33.x86_64
 Problem 4: cannot install the best update candidate for package kwin-common-5.20.4-2.fc33.x86_64
  - problem with installed package kwin-common-5.20.4-2.fc33.x86_64
  - nothing provides kf5-kwayland(x86-64) >= 5.78.0 needed by kwin-common-5.20.5-1.fc33.x86_64
 Problem 5: cannot install the best update candidate for package plasma-workspace-xorg-5.20.4-1.fc33.x86_64
  - problem with installed package plasma-workspace-xorg-5.20.4-1.fc33.x86_64
  - package plasma-workspace-xorg-5.20.5-1.fc33.x86_64 requires plasma-workspace = 5.20.5-1.fc33, but none of the providers can be installed
  - nothing provides kf5-plasma(x86-32) >= 5.78.0 needed by plasma-workspace-5.20.5-1.fc33.i686
  - nothing provides kf5-plasma(x86-64) >= 5.78.0 needed by plasma-workspace-5.20.5-1.fc33.x86_64
 Problem 6: cannot install the best update candidate for package plasma-workspace-wayland-5.20.4-1.fc33.x86_64
  - problem with installed package plasma-workspace-wayland-5.20.4-1.fc33.x86_64
  - package plasma-workspace-wayland-5.20.5-1.fc33.x86_64 requires plasma-workspace = 5.20.5-1.fc33, but none of the providers can be installed
  - nothing provides kf5-plasma(x86-32) >= 5.78.0 needed by plasma-workspace-5.20.5-1.fc33.i686
  - nothing provides kf5-plasma(x86-64) >= 5.78.0 needed by plasma-workspace-5.20.5-1.fc33.x86_64
 Problem 7: cannot install the best update candidate for package plasma-lookandfeel-fedora-5.20.4-1.fc33.noarch
  - problem with installed package plasma-lookandfeel-fedora-5.20.4-1.fc33.noarch
  - package plasma-lookandfeel-fedora-5.20.5-1.fc33.noarch requires plasma-workspace = 5.20.5-1.fc33, but none of the providers can be installed
  - nothing provides kf5-plasma(x86-32) >= 5.78.0 needed by plasma-workspace-5.20.5-1.fc33.i686
  - nothing provides kf5-plasma(x86-64) >= 5.78.0 needed by plasma-workspace-5.20.5-1.fc33.x86_64
 Problem 8: cannot install the best update candidate for package kwin-x11-5.20.4-2.fc33.x86_64
  - problem with installed package kwin-x11-5.20.4-2.fc33.x86_64
  - package kwin-x11-5.20.5-1.fc33.x86_64 requires kwin-common(x86-64) = 5.20.5-1.fc33, but none of the providers can be installed
  - nothing provides kf5-kwayland(x86-64) >= 5.78.0 needed by kwin-common-5.20.5-1.fc33.x86_64
 Problem 9: cannot install the best update candidate for package kwin-wayland-5.20.4-2.fc33.x86_64
  - problem with installed package kwin-wayland-5.20.4-2.fc33.x86_64
  - package kwin-wayland-5.20.5-1.fc33.x86_64 requires kwin-common(x86-64) = 5.20.5-1.fc33, but none of the providers can be installed
  - nothing provides kf5-kwayland(x86-64) >= 5.78.0 needed by kwin-common-5.20.5-1.fc33.x86_64
 Problem 10: cannot install the best update candidate for package kwin-5.20.4-2.fc33.x86_64
  - problem with installed package kwin-5.20.4-2.fc33.x86_64
  - package kwin-5.20.5-1.fc33.x86_64 requires kwin-common(x86-64) = 5.20.5-1.fc33, but none of the providers can be installed
  - nothing provides kf5-kwayland(x86-64) >= 5.78.0 needed by kwin-common-5.20.5-1.fc33.x86_64
(try to add '--skip-broken' to skip uninstallable packages)
2 Likes

Hi, you need this update to hit the stable repo:

https://bodhi.fedoraproject.org/updates/FEDORA-2021-b6c17b6872

You can install it from testing or wait until it is pushed to stable.

6 Likes

Like @ersen said, you need another set of updates that don’t reached stable repos yet.
If you don’t want to wait for that, you can run that command here an upgrade it immediately:

sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-b6c17b6872
2 Likes