Cannot install ubuntu font

Hi,

I’m brand new with Fedora, besides I worked about 20 years with Ubuntu. I cannot install Ubuntu.

  • Tried ln -s /fontfolder /usr/share/fonts/fontfolder;
  • Copied fonts to /usr/share/fonts;
  • Even execute this script:
wget http://font.ubuntu.com/download/ubuntu-font-family-0.80.zip
mkdir /tmp/ubuntu-font-family-0.80
unzip -j ubuntu-font-family-0.80.zip -d /tmp/ubuntu-font-family-0.80
rm -f ubuntu-font-family-0.80.zip
sudo mkdir /usr/share/fonts/ubuntu
sudo mv /tmp/ubuntu-font-family-0.80/*.ttf /usr/share/fonts/ubuntu
rm -rf /tmp/ubuntu-font-family-0.80
cd /usr/share/fonts/ubuntu
ttmkfdir > fonts.dir
fc-cache -fv

I couldn’t install Ubuntu font.
Any ideas to solve it?

The up-to-date download link is here:
https://design.ubuntu.com/font/

# User profile
wget -c -nc -P "$(xdg-user-dir DOWNLOAD)" \
    "https://assets.ubuntu.com/v1/0cef8205-ubuntu-font-family-0.83.zip"
unzip -o "$(xdg-user-dir DOWNLOAD)/0cef8205-ubuntu-font-family-0.83.zip" \
    "ubuntu-font-family-0.83/*.ttf" -d "${HOME}/.local/share/fonts"

# All users
sudo cp -R -f ${HOME}/.local/share/fonts/ubuntu-font-family-0.83 \
    /usr/share/fonts
sudo chmod 644 /usr/share/fonts/ubuntu-font-family-0.83/*.ttf

# Cleanup
gio trash -f "${HOME}/.local/share/fonts/ubuntu-font-family-0.83" \
    "$(xdg-user-dir DOWNLOAD)/0cef8205-ubuntu-font-family-0.83.zip"

Voilà, It worked! I’d rather a system solution, to all users, but this is better than nothing… Thx!

1 Like

I updated the script above.

You may try this:
dnf install http://mirror.yandex.ru/fedora/russianfedora/russianfedora/free/fedora/development/rawhide/x86_64/os//ubuntu-family-fonts-0.83-1.fc25.R.noarch.rpm
(searched from https://pkgs.org )