Cannot install wine on F33

Trying to install wine, getting broken dependencies, opened a bug too. dnf update --refsresh done, cache clearing done too. Any hints?

Last metadata expiration check: 0:08:45 ago on Sun 28 Mar 2021 01:55:26 PM CDT.
Error:
Problem: conflicting requests

  • package wine-6.3-1.fc33.i686 requires wine-core(x86-32) = 6.3-1.fc33, but none of the providers can be installed
  • package wine-6.3-1.fc33.x86_64 requires wine-core(x86-32) = 6.3-1.fc33, but none of the providers can be installed
  • package wine-5.18-2.fc33.i686 requires wine-core(x86-32) = 5.18-2.fc33, but none of the providers can be installed
  • package wine-5.18-2.fc33.x86_64 requires wine-core(x86-32) = 5.18-2.fc33, but none of the providers can be installed
  • package wine-core-6.3-1.fc33.i686 requires libgphoto2.so.6, but none of the providers can be installed
  • package wine-core-6.3-1.fc33.i686 requires libgphoto2_port.so.12, but none of the providers can be installed
  • package wine-core-6.3-1.fc33.i686 requires libgphoto2_port.so.12(LIBGPHOTO2_5_0), but none of the providers can be installed
  • package wine-core-5.18-2.fc33.i686 requires libgphoto2.so.6, but none of the providers can be installed
  • package wine-core-5.18-2.fc33.i686 requires libgphoto2_port.so.12, but none of the providers can be installed
  • package wine-core-5.18-2.fc33.i686 requires libgphoto2_port.so.12(LIBGPHOTO2_5_0), but none of the providers can be installed
  • package libgphoto2-2.5.27-1.fc33.i686 requires libcurl.so.4, but none of the providers can be installed
  • package libgphoto2-2.5.24-4.fc33.i686 requires libcurl.so.4, but none of the providers can be installed
  • package libcurl-7.71.1-8.fc33.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-minimal-7.71.1-8.fc33.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-7.71.1-7.fc33.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libcurl-minimal-7.71.1-7.fc33.i686 requires libnghttp2.so.14, but none of the providers can be installed
  • package libnghttp2-1.43.0-1.fc33.i686 is filtered out by modular filtering
  • package libnghttp2-1.41.0-3.fc33.i686 is filtered out by modular filtering
    (try to add ‘–skip-broken’ to skip uninstallable packages)

Gave me similar results with broken deps, so I removed that repo.

wine is in official repositories and you don’t need to add wine repository on Fedora 33. It will cause issues and many packages including Lutris need wine-core as a dependency which is already in the Fedora repositories. It will conflict if you use Wine repos. Can you tell which repositories you have enabled maybe some other repository is conflicting.

1 Like

dnf repolist
repo id repo name
fedora Fedora 33 - x86_64
fedora-cisco-openh264 Fedora 33 openh264 (From Cisco) - x86_64
fedora-modular Fedora Modular 33 - x86_64
opera Opera packages
rpmfusion-free RPM Fusion for Fedora 33 - Free
rpmfusion-free-updates RPM Fusion for Fedora 33 - Free - Updates
rpmfusion-nonfree RPM Fusion for Fedora 33 - Nonfree
rpmfusion-nonfree-updates RPM Fusion for Fedora 33 - Nonfree - Updates
updates Fedora 33 - x86_64 - Updates
updates-modular Fedora Modular 33 - x86_64 - Updates

Your repositories are fine !
*package libnghttp2-1.43.0-1.fc33.i686 is filtered out by modular filtering
in your logs.

can you do
sudo dnf clean all

sudo dnf update

and then try installing wine as this is just the case of mirror being out of sync or something.
https://bugzilla.redhat.com/show_bug.cgi?id=1919593

Done that, makes no difference. I think it’s just broken packaging, I’m able to install wine-core, and wine-mono, but not wine.

You can try wine-staging for latest wine as well. I am not sure but is “opera opera packages” for the opera browser ? Can you just disable it and try, as thats the only repo I don’t have. You can enable it back. You can do that in Software GUI as well.