Cannot remove automatically added printers

I have seen many different issues with printers in the forum, but I have not found an answer that helps me with this issue.

Event though I have cups-browsed disabled, existing printers in my network are being added to the Printers menu in Gnome. When I delete them, they automatically reappear.

Moreover, they are completely non-functional, since they are mapped to /dev/null.

Does anyone know if this is known issue? Is there any solution?

Also, what service or system is the one adding printers if cups-browsed is disabled?

Thanks in advance

2 Likes

Hi, maybe you can open http://localhost:631/admin from your browser. It will open your cups admin from browser.

Or you could also follow this guide to remove your printer from terminal.

Thank you very much for your suggestion. I didn’t know that there was a CUPS webserver to manage printers. It is quite convenient indeed. In this interface there are not unwanted printers, so management is easier.

However, the problem persists in the sense that every time that I try to print something from any Gnome app, I get this huge list of printers on top of the two real printers that I can use. Those printers populate the Gnome printer menu also, so, even though this CUPS interface allows to easily manage only with “real” printers, using them is not so easy -because of Gnome?-.

What process is adding those printers there? Because they are impossible to remove. They repopulate the dialog without need to reboot your system. As soon as you remove one, they reappear immediately.

:thinking: Please check /etc/cups/ppd directory. By default it should be empty.

Reference: here

… the printer will be defined and a .ppd file will be created in /etc/cups/ppd/ by querying the printer on the network.

Or you can try some commands from that doc to remove network printer.

When I was concerned by this problem I ended up with disabling avahi-daemon

sudo systemctl disable avahi-daemon.service --now
sudo systemctl disable avahi-daemon.socket --now

in addition to cups-browsed

sudo systemctl disable cups-browsed.service --now

But also because I never had the need of Apple’s Zeroconf architecture (also known as “Rendezvous” or “Bonjour”) [1]


  1. man avahi-daemon ↩︎

2 Likes

I may be seeing the same thing.
I have one network HP printer and it shows up in the cups web interface and when printing from the browser exactly as configured.
However, when I open sane to scan I see 3 printers to select from and I have to be careful to pick the right one.
One shows as airscan:… : one shows as I configured it with hpaio:… and the IP address as configured : The third shows similar to the proper one but the name is all in lower canse and has “queue=false” at the end. Only one will work with sane.

I also see the third printer above in the gnome settings → printers panel and if I remove it the same thing shows up with the next boot (sometimes sooner).

I never thought about avahi as the cause but will see if that can fix the problem for me. I have already disabled the service and the socket.

Immediately after disabling avahi I went into the gnome settings → printers panel and as soon as I unlocked the panel the extra printer disappeared. When I opened sane I note the extra printer has also disappeared there as well.

Thank you very much for the info about avahi and hopefully I do not need it for some other important purpose in the future.

@alciregi @computersavvy I’m bit confused, disabling the services mentioned above just like I want to work offline and then disabling network manager instead of turn it off from gnome setting. Are this necessary? I’m just wondering.

I just used the suggested actions of disabling those 2 avahi-daemon service & socket services. When I did so the extra printers disappeared from the gnome settings printers panel. I am waiting to see if that causes any other problems as I do not know if it will or won’t.

You can try the same and see if it eliminates the extra printer definitions, then over time see if it causes anything else to have a problem. Your choice to try that fix or not.

Note that this suggested fix has nothing to do with network manager or the network, only the automatically configured devices managed by avahi.

1 Like

Here’s the issue filed upstream:

After some tests, it seems that, as already mentioned before in this thread, the problem is the avahi daemon. It is not adding the printers, but only showing that they are available. Once disconnected from the network, those printers disappear.

I have tried to change the avahi daemon configuration to not include printers, but to no avail.

I hope that, from the issue linked by Federico, they provide the option in GNOME to not autodiscover printers.

Thank you everyone for your help.

2 Likes