Cannot still install Flatpak packages

I am trying install Telegram in Fedora 36 beta like below

flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo
flatpak install org.telegram.desktop

Get the following error generally solved by adding the remote

error: No remote refs found similar to ‘org.telegram.desktop’

AFAIK there was a Flatpak related bug in Fedora 36beta, but it should be solved by now, since I have the latest updates.

How could I fix this? Seems like

remote-add

was not successful.

The instructions on FlatHub say the command is:

$ flatpak install flathub org.telegram.desktop

For some reason flathub is disabled after installation on Fedora 36 Beta:

$ flatpak remotes --show-disabled
Name           Options
fedora         system,oci
fedora-testing system,disabled,oci
flathub        system,disabled

Enable it:

$ flatpak remote-modify --enable flathub

Then the installation is possible.

1 Like
❯ flatpak install flathub org.telegram.desktop
Looking for matches…
error: Unable to load summary from remote flathub: Can't fetch summary from disabled remote ‘flathub’

Thanks, it worked!