Cannot turn Bluetooth on and off

I’m on Fedora 34 and I cannot turn Bluetooth on and off.
If I go to the upper right corner of the panel and lick on “Bluetooth off”->“Turn on”, nothing happens.
Except that now the Bluetooth is still off but the “Turn On” button became “Turn Off”.

Some thing If I go to the Settings, I cannot turn Bluetooth on and off.

Here is the “Bluetooth Off” / “Turn Off” picture

bluetooth_off_off

Can you run journalctl -f in the terminal (this will show new messages as they are appended to the journal) and try to turn on/off bluetooth again and share the messages you got in the journal?

I am making some fast-paced changes to my system and mess things up.

My previous message was actually running on an X11 session and is not valid. The behaviour on X11 changes. Now I am on Wayland again.

So the current situation is the one of the screenshot.

Upper right corner shows: Bluetooth Off / Turn Off

Clicking on “Turn Off” shows:

May 09 19:39:22 fedora systemd[1]: Starting Load/Save RF Kill Switch Status...
May 09 19:39:22 fedora systemd[1]: Started Load/Save RF Kill Switch Status.
May 09 19:39:22 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 09 19:39:27 fedora systemd[1]: systemd-rfkill.service: Deactivated successfully.
May 09 19:39:27 fedora audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 09 19:39:29 fedora systemd[1970]: dbus-:1.2-org.gnome.ControlCenter.SearchProvider@6.service: Deactivated successfully.

Upper right corner is now Bluetooth Off / Turn On

Clicking on “Turn On” shows:

May 09 19:40:21 fedora systemd[1]: Starting Load/Save RF Kill Switch Status...
May 09 19:40:21 fedora systemd[1]: Started Load/Save RF Kill Switch Status.
May 09 19:40:21 fedora audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
May 09 19:40:26 fedora systemd[1]: systemd-rfkill.service: Deactivated successfully.
May 09 19:40:26 fedora audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

Upper right corner is now Bluetooth Off / Turn Off again.

“Bluetooth Off” → “Bluetooth settings” shows the slider in the upper right corner of the window as off.

Clicking on the slider moves the slider to the right in the “On” position, but the windows still shows Bluetooth as off, as displayed in the following screenshot:

EDIT: Logging out and back in worse the situation. Audio does not work anymore. I cannot hear anything. Upper right corner is back into Bluetooth Off / Turn On.

EDIT2: Rebooting improves the situation. At the login screen, the headset says “Bluetooth connected”. After login headset says “Bluetooth disconnected”. Then I go in the Bluetooth settings and I am able to connect the headset. I can hear audio through it correctly.

1 Like

Reporting that I am also experienceing this issue. Fedora 34. Bluetooth works sometimes, but am currently unable to turn on/off. If I open the main settings window, the toggle switch will properly toggle, but it always says bluetooth turned off

1 Like

Exact same issue here.

The issue has been identified and fixed in Rawhide. An update should soon be available for F34 as well. See RHBZ#1944482 for more details.

In the meantime, a sudo systemctl restart bluetooth should get your Bluetooth going again.

1 Like

I confirm this is fixed in the latest update.

Now when the Bluetooth is off, I can click on the menu item and it gets turned on.

Then the menu item becomes “Bluetooth on” and has a “Turn Off” button underneath that works.

Thanks :slight_smile:

1 Like