Cannot upgrade Silverblue

I’m trying to upgrade my Fedora 33 Silverblue system, just like normal, but it’s been already about one week I just can’t. Check it out:

➤ rpm-ostree status
State: idle
Deployments:
● ostree://fedora:fedora/33/x86_64/silverblue
                   Version: 33.20210207.0 (2021-02-07T00:56:44Z)
                BaseCommit: 14706469057c430ff7484aee7014bc44ceed975c2367c60da5b4927918aaaeab
              GPGSignature: Valid signature by 963A2BEB02009608FE67EA4249FD77499570FF31
           LayeredPackages: ardour6 ardour6-backend-alsa ardour6-backend-jack ardour6-backend-pulseaudio cascadia-code-fonts code compat-ffmpeg28 epiphany
                            fedora-workstation-repositories ffmpeg firefox-x11 firewall-config fish gnome-boxes gnome-shell-extension-gpaste google-chrome google-chrome-stable
                            gstreamer1-plugin-openh264 hunspell-es java-latest-openjdk kmod-nvidia langpacks-es linphone lutris moby-engine mozilla-openh264 openssh-askpass pipx
                            python3-invoke steam studio-controls sushi tcpdump totem xorg-x11-drv-nvidia xorg-x11-drv-nvidia-cuda
             LocalPackages: xow-0.4-1.fc32.x86_64 jamulus-3.6.0-7.fc33.x86_64 rpmfusion-nonfree-release-33-1.noarch rpmfusion-free-release-33-1.noarch

  ostree://fedora:fedora/33/x86_64/silverblue
                   Version: 33.20210201.0 (2021-02-01T01:33:02Z)
                BaseCommit: 0b12bb84583d7f31c28b917b915d4b3f05fa9960fbc51160984f5486c11d647b
              GPGSignature: Valid signature by 963A2BEB02009608FE67EA4249FD77499570FF31
           LayeredPackages: ardour6 ardour6-backend-alsa ardour6-backend-jack ardour6-backend-pulseaudio cascadia-code-fonts code compat-ffmpeg28 epiphany
                            fedora-workstation-repositories ffmpeg firefox-x11 firewall-config fish gnome-boxes gnome-shell-extension-gpaste google-chrome google-chrome-stable
                            gstreamer1-plugin-openh264 hunspell-es java-latest-openjdk kmod-nvidia langpacks-es linphone lutris moby-engine mozilla-openh264 openssh-askpass pipx
                            python3-invoke steam studio-controls sushi tcpdump totem xorg-x11-drv-nvidia xorg-x11-drv-nvidia-cuda
             LocalPackages: xow-0.4-1.fc32.x86_64 jamulus-3.6.0-7.fc33.x86_64 rpmfusion-nonfree-release-33-1.noarch rpmfusion-free-release-33-1.noarch

➤ rpm-ostree upgrade
2 metadata, 0 content objects fetched; 788 B transferred in 2 seconds; 0 bytes content written
Checking out tree 20965de... done
Enabled rpm-md repositories: rpmfusion-nonfree-updates fedora updates rpmfusion-nonfree-steam google-chrome fedora-cisco-openh264 code rpmfusion-free rpmfusion-nonfree-nvidia-driver rpmfusion-nonfree rpmfusion-free-updates updates-archive
rpm-md repo 'rpmfusion-nonfree-updates' (cached); generated: 2021-02-25T22:10:51Z
rpm-md repo 'fedora' (cached); generated: 2020-10-19T23:27:19Z
rpm-md repo 'updates' (cached); generated: 2021-02-26T00:31:13Z
rpm-md repo 'rpmfusion-nonfree-steam' (cached); generated: 2020-11-18T22:19:03Z
rpm-md repo 'google-chrome' (cached); generated: 2021-02-25T20:44:55Z
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2020-08-25T19:10:34Z
rpm-md repo 'code' (cached); generated: 2021-02-26T22:50:59Z
rpm-md repo 'rpmfusion-free' (cached); generated: 2020-10-16T17:39:10Z
rpm-md repo 'rpmfusion-nonfree-nvidia-driver' (cached); generated: 2021-02-11T16:17:16Z
rpm-md repo 'rpmfusion-nonfree' (cached); generated: 2020-10-16T18:04:38Z
rpm-md repo 'rpmfusion-free-updates' (cached); generated: 2021-02-25T21:32:58Z
rpm-md repo 'updates-archive' (cached); generated: 2021-02-27T02:15:21Z
Importing rpm-md... done
Resolving dependencies... done
Checking out packages... done
Running pre scripts... done
Running post scripts... done
error: Running %post for akmod-nvidia: Executing bwrap(/bin/sh): El proceso hijo terminado por la señal 1; run `journalctl -t 'rpm-ostree(akmod-nvidia.post)'` for more information

I try that command of journalctl -t 'rpm-ostree(akmod-nvidia.post)' and I find these logs:

rpm-ostree(akmod-nvidia.post)[31467]: Building /usr/src/akmods/nvidia-kmod-460.39-1.fc33.src.rpm for kernel 5.10.18-200.fc33.x86_64
rpm-ostree(akmod-nvidia.post)[31529]: advertencia:Found bdb Packages database while attempting sqlite backend: using bdb backend.
rpm-ostree(akmod-nvidia.post)[31529]: advertencia:user mockbuild does not exist - using root
rpm-ostree(akmod-nvidia.post)[31529]: advertencia:group mock does not exist - using root
rpm-ostree(akmod-nvidia.post)[31529]: advertencia:user mockbuild does not exist - using root
rpm-ostree(akmod-nvidia.post)[31529]: advertencia:group mock does not exist - using root
rpm-ostree(akmod-nvidia.post)[31529]: Instalando /usr/src/akmods/nvidia-kmod-460.39-1.fc33.src.rpm
rpm-ostree(akmod-nvidia.post)[31529]: Construyendo las plataformas de destino: x86_64
rpm-ostree(akmod-nvidia.post)[31529]: Construyendo para el destino x86_64
rpm-ostree(akmod-nvidia.post)[31529]: setting SOURCE_DATE_EPOCH=1611619200
rpm-ostree(akmod-nvidia.post)[31529]: error: Fallo al construir las dependencias:
rpm-ostree(akmod-nvidia.post)[31529]:         /usr/bin/kmodtool es necesario por nvidia-kmod-3:460.39-1.fc33.x86_64
rpm-ostree(akmod-nvidia.post)[31529]:         gcc es necesario por nvidia-kmod-3:460.39-1.fc33.x86_64
rpm-ostree(akmod-nvidia.post)[31529]:         xorg-x11-drv-nvidia-kmodsrc >= 3:460.39-1 es necesario por nvidia-kmod-3:460.39-1.fc33.x86_64

Any ideas? AFAIK I have all those dependencies it wants :man_shrugging::

➤ which kmodtool
/usr/bin/kmodtool

➤ which gcc
/usr/bin/gcc

➤ rpm -q xorg-x11-drv-nvidia-kmodsrc
advertencia:Found bdb Packages database while attempting sqlite backend: using bdb backend.
xorg-x11-drv-nvidia-kmodsrc-460.39-1.fc33.x86_64
1 Like

Please check these two TOPIC:

Regards.,

1 Like

Thank you, I solved it with this solution in one of those posts: Can't update Fedora Silverblue with nvidia drivers - #3 by aitvaras

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.