Can't connect to wifi after update (bcm4360 with broadcom-wl driver)

Then, for some strange reason the modules isn’t built; I personally use the dkms driver from UnitedRPMs; and works great, 0 problems… If you are tired, maybe works for you…

  1. Enable repository

  2. Install the driver

dnf remove broadcom-wl kmod-wl

dnf install broadcom-wl-dkms

I just tried that and it doesn’t work either… Still “connecting…”, then “activation failed”, then trying to connect again.
Interestingly, with broadcom-wl I actually noticed that (once) after trying to connect for like an hour it eventually worked (temporarily - attempting to change networks or reconnecting reset the whole cycle)

2 Likes

I told you hahaha :smile:

Any other ideas? It seems connecting eventually works but takes an hour or two each time…

Unfortunately, I think this seems to indicate a driver issue. We’ll have to look into a bit. Maybe worth investing in a cheap wifi dongle thing in the meantime. You get cheap ones for a fiver on amazon etc.

Before I got my new system (a Thinkpad), I had the broadcom wifi too, and even though support has improved considerably, it’s still buggy at times :slightly_frowning_face:

After upgrading to F30 I have the same problem with a BCM4352, Wifi@F29 worked without problems. Wifi is available only after some manual connects.

03:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4352 802.11ac Wireless Network Adapter (rev 03)
	Subsystem: AzureWave Device 2123
	Kernel driver in use: wl
	Kernel modules: bcma, wl

This bug has already been described. https://bugzilla.redhat.com/show_bug.cgi?id=1703745

For an interim solution, you could either use the test build from koji at https://koji.fedoraproject.org/koji/taskinfo?taskID=34599725 or wait for the official update.

5 Likes

Hello,

I have the same problem, and after install de wpa_suppliment 2.8 Works.

Removing the wl module & instaling the build from koji (& then rebooting) worked for me as well!

2 Likes

Same problem. RPMFusion driver won’t work. Haven’t tried others. Wish this could be as easy as in ubuntu.

Easy to fix with the suggested test build from koji. No problem anymore.

3 Likes

Was just looking into installing fedora 30 on my laptop when I came across this issue.

Has anyone tried using the 2.8 branch of wpa_supplicant from rawhide?

I used and work on my Mac same broadcom wifi card

1 Like

Downgrading specifically to wpa_supplicant-2.6-17.fc29.x86_64.rpm and then excluding wpa_supplicant in dnf.conf has been the only solution that worked for me so far. I’m using a MacBook Pro 7,1 and with this method I still have a few issues with WiFi but it’s very sparse.

2 Likes

The updated “wpa_supplicant” solves the issue (isn’t problem with the driver), if you don’t want wait the update you can download HERE :wink:

2 Likes

It would be nice to know when this updated package will be in the fedora30 repos. :slight_smile:

All updates must go through the Fedora QA (Quality assurance system). So, this update is now in “testing”. It needs users to test and confirm the fix—by providing positive or negative karma. When it receives the required karma, it will automatically be pushed to “stable” for all users to use.

3 Likes

Personally I can’t see the packaged yet, maybe waiting for replication.

I use a lot fedora-easy-karma is a CLI interface, the procedure I follow is:

  • install fedora-easy-karma
  • Update the package from testing, enabling temporaly with

dnf update --enablerepo=updates-testing packed

  • start fedora-easy-karma
    • You can give +1, -1, 0
    • and a Comment
  • You’re starting to receive e-mail about comment in the package

Regards.,

1 Like

I’ll have to wait for the official update to have broadcom WiFi (BCM43142 on a HP-Notebook) working again. Hope the official update will come soon.
Doing all mentioned above failed.

dnf update --enablerepo=updates-testing wpa_supplicant-2.8-1

Last metadata expiration check: 0:09:04 ago on Sat 11 May 2019 12:26:10 PM CEST.
No match for argument: wpa_supplicant-2.8-1

and:

dnf install wpa_supplicant-2.8 --enablerepo=updates-testing

Last metadata expiration check: 0:00:35 ago on Sat 11 May 2019 12:26:10 PM CEST.
No match for argument: wpa_supplicant-2.8
Error: Unable to find a match

Downloading and trying to install it:

rpm --install wpa_supplicant-2.8-1.fc30.src.rpm wpa_supplicant-2.8-1.fc30.x86_64.rpm wpa_supplicant-gui-2.8-1.fc30.x86_64.rpm

Gives a real long list of conflicting packages. Tried to remove the old version first, but dnf wanted te remove a whole list of Python packages as so called “unused dependencies”, which they are not. So I’ll have to wait and I hope the official update will come really soon.

dnf update --enablerepo=updates-testing wpa_supplicant

should do it. Once the update is pushed to bodhi, it is pushed to the mirrors worldwide and that takes time. Please check again in a few hours or so.