Can't create active bonding interface

Hey all,

I recently decided to try fedora as it supports newer hardware out of the box. While tinkering around i wanted to create a bonded interface, but with no luck.

i tried different guides i found on the fedora wiki and other websites. I used the nmcli to configure the bond and slave interfaces but it does not show up. then i tried manually configuring the interfaces in /etc/sysconfig/network-scripts. after this i added /etc/modprobe.conf with the allias and tried ifup bond0.
and get

“Error: unknown connection ‘/etc/sysconfig/network-scripts/ifcfg-bond0’.”

my configuration for ifcfg-bond0
BONDING_OPTS=“downdelay=200 miimon=100 mode=802.3ad updelay=200”
TYPE=Bond
BONDING_MASTER=yes
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=dhcp
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=yes
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_PRIVACY=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=“bond0”
UUID=7bbc1c1b-f277-43a7-8cb7-a7f7f6249210
DEVICE=bond0
ONBOOT=yes

somehow it looks like the gnome network manager (via settings menu) is commanding and just throws on the standard auto wired connection profile.

clearly im doing something wrong or missing a step. Could someone point me to the right guide or toss in an opinion?

Hardware setup:
Amd system with Intel X520-DA2 card connected over lc fiber to a unifi switch (in LACP mode)

Guides used:

In the Red Hat Customer Portal:
Did your tried NetworkManager-tui’s nmtui from the section 7.2?

sorry for the late reply.
So i freshly installed the system and tried it with nmtui. however when trying to activating the bond it fails.

i finally got it to work :slight_smile:

i used nmcli (nm-connection-editor)

deleted all the profiles
used team instead of bond.
added the ethernet slaves
then in advanced changed runner to LACP with transmission balancer to Basic

worked perfectly afterwards. tested it with iperf + file transfer and online speed test and saw it divided equally!

Thank for the reply! hope this saves someone else hours of headache

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.