Can't get the sound to work with any linux distro I've tried so far, please help!

Also I ran into the following article while trying to troubleshoot ALSA: Alsa Opensrc Org - Independent ALSA and linux audio support site.

Then I ran the following commands:

[david@fedora ~]$ lspci | egrep -i audio
00:0e.0 Multimedia audio controller: Intel Corporation Celeron/Pentium Silver Processor High Definition Audio (rev 06)
[david@fedora ~]$ sudo cat /proc/asound/cards
 0 [camera         ]: USB-Audio - USB camera
                      SunplusIT Inc USB camera at usb-0000:00:15.0-6, high speed
 1 [sofessx8336    ]: sof-essx8336 - sof-essx8336

So if I am understanding this correctly, ALSA definitely seems to not be able to recognize my soundcard?

Hi Dave, your soundcard is detected as card number 1, the sof-essx8336. It is coincidentally probably the same as mine.

You could try to select your card, with an ALSA utility like alsamixer. Maybe it is needed to set card 1 as default as well. See for example How to set your default sound card . - antiX-forum.

I got my card working with Fedora 36 with all the latest updates applied, i.e. kernel 5.18.5 and sof-firmware 2.1.1. I had to increase the volume and correct the balance to hear any sound. It is very soft in my case. You could also try if you can hear something with a headset.



My drivers were updated, but what fixed it for me was messing with the sound card settings for sof-essx8336 in alsamixer. I just got some music playing in the background and went through the list of settings and unmuted/turned up every one of them until I could hear the music.

The sound balance does seem a bit wonky right now but i’m sure I can improve it by messing with the settings.

Thank you so much @josquin-69 and everyone else!

1 Like


Glad to hear, that did the trick for you :smile: . As far as I know, support for the sof-essx8336 is relatively new and still a work in progress. Hopefully future versions of the sof-firmware (2.2 and above) will improve the support, both for you and me.

If using pipewire, you may be able to correct the balance somewhat with EasyEffects (see GitHub - wwmm/easyeffects: Limiter, compressor, convolver, equalizer and auto volume and many other plugins for PipeWire applications). It is available in the software center, both as an RPM-package and a Flatpak application.

Kind regards from the Netherlands,