Can't install any plasma addons

,

Also, take a look at this:

deltarpm

boolean

When enabled, DNF will save bandwidth by downloading much smaller delta RPM files, rebuilding them to RPM locally. However, this is quite CPU and I/O intensive. Default is True.

deltarpm_percentage

integer

When the relative size of delta vs pkg is larger than this, delta is not used. Default value is 75 (Deltas must be at least 25% smaller than the pkg). Use 0 to turn off delta rpm processing. Local repositories (with [file://](file:///) baseurl) have delta rpms turned off by default.

(Source.)

So you could try disabling deltarpm, perhaps.

Are you able to use dnf in the terminal and can you update the system with dnf.
sudo dnf upgrade --refresh
I’m pretty sure Discover does not use dnf.

It seems there is a bug in Plasma so I’m guessing there should be an update soon.

1 Like

I concur. I’m also having the same issue.
Hopefully KDE 5.25 will be pushed to Fedora repositories soon.

Can confirm. I have this issue too.

It looks like the issue is caused by a bad update. Hopefully it gets fixed soon.

For those interested.
https://bugs.kde.org/show_bug.cgi?id=455540
https://bugreports.qt.io/browse/QTBUG-94470

Thanks for that.
Looks as if it isn’t fixed in KDE 5.25 either based on the last post from 4 hours ago of a user getting the same error in 5.25.

I have installed the dnf group “kde-desktop” two times over the last three days on two different machines, without any issues. Installing add-ons was no problem on either one.

(See my post above.)

Thanks for the suggestions ivanhoe. I ended up just opening a KDE bug report and can confirm what Joe says. They mentioned those links detailing the issue as well as a “possibly related merge request” as they phrased it:

So hopefully that fixes it! Doesn’t seem to be affecting everyone.

Cheers

Same issue here. dnf through konsole updates, but if i try to download software through discovery or add ons, it gives me the too many streams error. Hope it gets fixed soon

This appears to be a QT bug that will be fixed in the next update. I’ve seen this problem mentioned across multiple distros with KDE/ Plasma.

I`m trying out Fedora36 it wored fine in KDE about 3 weeks ago. Today, I made a fresh install perhabs to use it as my daily driver -plasma addons not working. I also used the ISO which I downloaded 3 weeks ago and tried if it works with no Sys upadtes same error.
FYI
I use Arch too on a Laptop with KDE 5.25 no issue at all works fine.

KDE have updated the bug report confirming the fix is in Qt 5.25.1 for anyone interested.

https://bugs.kde.org/show_bug.cgi?id=455540

2 Likes

@eskay993 Thanks a lot, so it will working soon again.

Today I got sys update hopefully it will fix it but I got another ERROR message:
Unknown open collaboration service API error. (0)
How to fix this?
This is starting to annoy me. I’m thinking about it to switch to Arch?

Would not help to switch to Arch the problem is with QT, not the base distro.

@Walter, you are right but I’ve no idea at the moment.
Who’s is updating Qt KDE isn’t and why I have no issues on my laptop with Arch?
Greetings

1 Like

That’s weird. Maybe a fix is already out and Arch got it first? Not sure. I had just tried it in Arco KDE and the error is still there. But there’s a small delay from Arch updates to Arco’s updates.

Update came out today that seems to have fixed the issue Should be qt5-qtbase 5.5.15.3.

2 Likes