Can't login to F30

Hi everybody, I using fedora 30. recently I can’t login with admin user. So it’s possible and i can login to root and other user. latest login log at below link :

http://s000.tinyupload.com/?file_id=82939458266184684571

1 Like

You have the following options:

1 Like

Can we please have some more information here:

  • are you using Gnome?
  • are you unable to login to Gnome with your “admin” user?
  • by “admin” user, do you mean “root”, or another user that was added as “administrator”?

Finally—when did this issue start? Was it after an update, or did you change any user settings?

Once we know all this, we can start looking into what the issue maybe.

1 Like

1- yes, I using gnome.
2- yes
3- another user
4- i don’t know exactly, but i think this issue started after a upgrade!!!

OK, thanks—so it is limited to this one user account. What happens when you try to login?

after typing user&password and then click enter , goes to login process, but after 1 seconds it returns to login page!!!

That generally implies that gnome-shell is crashing, which is usually caused by extensions.

Please disable all your extensions using the steps given here and see if that fixes the issue:

https://docs.fedoraproject.org/en-US/quick-docs/gnome-shell-extensions/#_enabling_disabling_and_changing_settings_for_gnome_shell_extensions 25

There are a few questions on the same topic. For example:

1 Like

i deleted all extensions directories with terminal. but nothing happened.

Have you tried logging in to Xorg session?

You have to select your admin, then enter the password, then click on a gear icon and select “Gnome on Xorg” – and only after that click “Enter” or “Login”.


Also it could be easier (and faster) to make a new admin user – as @vgaetera suggested right away – if you don’t have many important data and settings etc. associated with your current admin user.

1 Like

yes i can login with xorg. but keyboard not working. display is very Confused. it’s not possible to run a program and has other problems.

If the other non-admin users are working with Wayland, I don’t see why an admin user wouldn’t. Is there a known issue that we’re not aware of, for example? I’ve got 3 machines running gnome-shell on Wayland fine with admin accounts.

OK—so can you please use a virtual-terminal (ctrl alt f3) and see what journalctl -b says after such a failed login attempt? That will tell us what is keeping gnome-shell from loading.

https://docs.fedoraproject.org/en-US/quick-docs/viewing-logs/

http://s000.tinyupload.com/?file_id=82939458266184684571

latest log relation to admin user

It’s obviously some settings in this current account causing this (as other accounts are working fine). You’ve already checked / dismissed the extensions options. Xorg login is just something that’s really easy to try and has some (though small) chance to give us some idea about what’s wrong.


This part looks definitely not right, but I don’t know what to do about it. Maybe we can delete notification cache somehow?

Sep 19 20:35:22 dhcppc0 gnome-shell[6577]: JS ERROR: TypeError: appId is null
                                           objectPathFromAppId@resource:///org/gnome/shell/ui/notificationDaemon.js:609:5
                                           GtkNotificationDaemonAppSource@resource:///org/gnome/shell/ui/notificationDaemon.js:622:26
                                           _ensureAppSource@resource:///org/gnome/shell/ui/notificationDaemon.js:737:22
                                           _loadNotifications/<@resource:///org/gnome/shell/ui/notificationDaemon.js:761:30
                                           _loadNotifications@resource:///org/gnome/shell/ui/notificationDaemon.js:755:13
                                           GtkNotificationDaemon@resource:///org/gnome/shell/ui/notificationDaemon.js:725:9
                                           NotificationDaemon@resource:///org/gnome/shell/ui/notificationDaemon.js:825:39
                                           _initializeUI@resource:///org/gnome/shell/ui/main.js:177:26
                                           start@resource:///org/gnome/shell/ui/main.js:124:5
                                           @<main>:1:31
Sep 19 20:35:22 dhcppc0 gnome-shell[6577]: Value 18446744073709551615 cannot be safely stored in a JS Number and may be rounded
Sep 19 20:35:22 dhcppc0 gnome-shell[6577]: Value 18446744073709551615 cannot be safely stored in a JS Number and may be rounded
1 Like

I had a similar issue which required to reset the related dconf key as a workaround.
Perhaps the we can isolate it if we rename the dconf file:

mv ${HOME}/.config/dconf{,.bak}

I renamed it. but nothing happened.

1 Like

There are a few interesting bits in the log for starters:

Sep 19 20:35:33 dhcppc0 systemd[1]: Stopping User Manager for UID 1000...
Sep 19 20:35:23 dhcppc0 org.gnome.Shell.desktop[6177]: Errors from xkbcomp are not fatal to the X server
Sep 19 20:35:23 dhcppc0 org.gnome.Shell.desktop[6177]: > Internal error:   Could not resolve keysym XF86RotationLockToggle
Sep 19 20:35:23 dhcppc0 org.gnome.Shell.desktop[6177]: > Internal error:   Could not resolve keysym XF86MonBrightnessCycle
Sep 19 20:35:23 dhcppc0 org.gnome.Shell.desktop[6177]: >                   X11 cannot support keycodes above 255.
Sep 19 20:35:23 dhcppc0 org.gnome.Shell.desktop[6177]: > Warning:          Unsupported maximum keycode 569, clipping.
Sep 19 20:35:23 dhcppc0 org.gnome.Shell.desktop[6177]: The XKEYBOARD keymap compiler (xkbcomp) reports:
Sep 19 20:35:22 dhcppc0 systemd[6440]: Started Sound Service.

Doesn’t seem fatal, though.

Sep 19 20:35:22 dhcppc0 systemd[6440]: dbus-:1.2-org.freedesktop.portal.IBus@0.service: Succeeded.
Sep 19 20:35:22 dhcppc0 at-spi2-registryd[6654]:       after 21 requests (21 known processed) with 0 events remaining.
Sep 19 20:35:22 dhcppc0 at-spi2-registryd[6654]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":2"
Sep 19 20:35:22 dhcppc0 gnome-session-binary[6491]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Sep 19 20:35:22 dhcppc0 gnome-session-binary[6491]: Unrecoverable failure in required component org.gnome.Shell.desktop
Sep 19 20:35:22 dhcppc0 gnome-session[6491]: gnome-session-binary[6491]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
Sep 19 20:35:22 dhcppc0 rtkit-daemon[816]: Supervising 4 threads of 2 processes of 2 users.
Sep 19 20:35:22 dhcppc0 org.gnome.Shell.desktop[6577]: (EE) failed to read Wayland events: Connection reset by peer
Sep 19 20:35:22 dhcppc0 audit[1]: SERVICE_START pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=geoclue comm="systemd" exe="/usr/l>
Sep 19 20:35:22 dhcppc0 systemd[1]: Started Location Lookup Service.
Sep 19 20:35:22 dhcppc0 gnome-shell[6577]: Execution of main.js threw exception: Script <main> threw an exception
Sep 19 20:35:22 dhcppc0 gnome-shell[6577]: JS ERROR: TypeError: appId is null
                                           objectPathFromAppId@resource:///org/gnome/shell/ui/notificationDaemon.js:609:5
                                           GtkNotificationDaemonAppSource@resource:///org/gnome/shell/ui/notificationDaemon.js:622:26

That’s a gnome-shell crash there. Not sure what’s causing the notification error, though.

You can create a backup directory and move all your data and settings there.
Then you should be able to log in and selectively return the files.

2 Likes

I renamed .local directory and problem was solved. thank a lot to @hedayat.

4 Likes

Oops. Good, if you need you can move the contents of your old .local to the new one one by one to see when the problem appears.

Note: he asked the question in Persian too, and I was following there.
@msm1365 It’d be probably better to only ask once, so that we are coordinated

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.