Can't Power Off & X-Org Every Time I Logout

So, there is NO Power Off Button in the Menu & Even after using Keyboard Shortcut / Physical Button, That Power Off / Restart Popup Comes BUT Pressing those Option don’t do anything.

In short, I CAN’T SHUTDOWN MY PC. Need to do Force Shutdown by Keep Pressing Physical Button.

And Every time I get Logged out / Restart - The Default selected option is X-Org I need to select Wayland every single time!

Fedora 32 x86_64 Beta
Kernel: 5.6.2-301GNOME 3.36.1

It was working fine before, I think this started happening when Updated my system from
Kernel 5.6 => 5.6.2
And also upgraded gnome-shell from 3.36.1 => 3.36.1 release 3
OR maybe when due to Power Outage, PC suddenly got shutdown. (More Possibility)

Can’t enable systemd-logind & it’s status gives this logs. https://pastebin.com/jHAajZee Also included Poweroff.target status logs

While doing reboot manually from terminal, I get this. sudo reboot works fine.

Failed to set wall message, ignoring: Action org.freedesktop.login1.set-wall-message is not registered
Failed to reboot system via logind: Action org.freedesktop.login1.reboot is not registered
Failed to open initctl fifo: Permission denied
Failed to talk to init daemon.

Boot into an older kernel and see if the problem persists. (before boot hit ESC to see the grub boot menu)

I tried that already. No Luck :frowning:
Can’t enable systemd-logind & it’s status gives this logs.
https://pastebin.com/jHAajZee

Anyone knows How to Fix that, Wayland / X-org issue?

I’ve never had this happen, but here is my best guess. First thing I would try is update the system then reboot to see if its fixed. Perhaps its a known bug thats already been patched:
$ sudo dnf update
$ shutdown -r now

Regarding xorg default: Perhaps try looking in /etc/gdm/custom.conf and check if WaylandEnable=false is still commented out. If this is uncommented (missing the #) then the system will default to xorg. Here’s an example of a custom.conf that defaults to Wayland:

[user@#$#$#$# ~]$ cat /etc/gdm/custom.conf 
# GDM configuration storage

[daemon]
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false

AutomaticLoginEnable=False
AutomaticLogin=user

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

Good luck. I’ll post back if I come across anything else.

That file is right. Its Commented*

Fixed all those issues. There were not only these 2 issues but realized there were a lot more!
It was Flatpak who messed up my System, but then Timeshift saved Me!
Full Story - https://www.reddit.com/r/Fedora/comments/g261n6/flatpak_messed_up_my_system_timeshift_saved_me/

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.